Bug 31465 - Link system preference tabs to correct manual pages
Summary: Link system preference tabs to correct manual pages
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Documentation (show other bugs)
Version: master
Hardware: All All
: P5 - low trivial (vote)
Assignee: Martin Renvoize
QA Contact: Testopia
URL:
Keywords:
: 2326 32153 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-08-25 21:41 UTC by Lucas Gass
Modified: 2022-11-27 00:06 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.11.00, 22.05.07, 21.11.14


Attachments
Bug 31465: Correct help link for preferences (2.21 KB, patch)
2022-09-16 10:46 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 31465: (follow-up) Link to preference tabs directly (3.10 KB, patch)
2022-09-16 11:35 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 31465: Correct help link for preferences (2.25 KB, patch)
2022-09-18 21:13 UTC, David Nind
Details | Diff | Splinter Review
Bug 31465: (follow-up) Link to preference tabs directly (3.15 KB, patch)
2022-09-18 21:13 UTC, David Nind
Details | Diff | Splinter Review
Bug 31465: Correct help link for preferences (2.31 KB, patch)
2022-09-20 20:25 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 31465: (follow-up) Link to preference tabs directly (3.21 KB, patch)
2022-09-20 20:25 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Lucas Gass 2022-08-25 21:41:15 UTC
Go to a link like this one:

https://koha-community.org/manual/21.11/en/html/systempreferences.html

Notice in the top left corner it has 20.05, but the link it is for 21.11.
Comment 1 Katrin Fischer 2022-08-28 15:31:01 UTC
The versions of the different branches look correct in git. I wonder if there is something wrong with building the manuals?

https://gitlab.com/koha-community/koha-manual/-/blob/master/source/index.rst

https://gitlab.com/koha-community/koha-manual/-/blob/manual21.11.x/source/conf.py
Comment 2 Lucas Gass 2022-09-15 20:58:08 UTC
Some more info here:

"Even though it says 20.05 it is actually 21.11 and if I do an additional search where it says Koha Manual 21.05, the search is in 21.11 and the manual number depicted in the green background switches to 21.11."
Comment 3 Martin Renvoize 2022-09-16 05:47:12 UTC
It'll be the pipeline task... I'll fix it today. I didn't actually think we'd branched yet as it also says 22.05 is the Development manual too.

I
Comment 4 Katrin Fischer 2022-09-16 07:37:32 UTC
(In reply to Martin Renvoize from comment #3)
> It'll be the pipeline task... I'll fix it today. I didn't actually think
> we'd branched yet as it also says 22.05 is the Development manual too.
> 
> I

I think we didn't branch, but it looks like we might sell 20.05 as 21.11 manual (so the problem is in the older manuals)

https://koha-community.org/manual/21.05/en/html/systempreferences.html

21.05 also says 20.05 ...
Comment 5 Martin Renvoize 2022-09-16 10:46:48 UTC
Created attachment 140702 [details] [review]
Bug 31465: Correct help link for preferences

This patch updates the mapping to reflect the split and rename of the
preferences section of the manual.

Test plan
1) Hitting 'Help' on any tab except for 'Local use' should lead you to
   the globalpreferences section of the manual for your Koha version.
2) Hitting 'Help' on the 'Local use' tab should take you directly to the
   'localusepreferences' manual page.

NOTE: I have now updated the manual build pipeline to remove
renamed/deleted files so prior to this patch you should now see a 404
response when clicking Help from these pages.  Before I made that
change, we had the old file hanging around, so you actually got an
outdated manual page disguised as a more recent version.
Comment 6 Martin Renvoize 2022-09-16 11:35:30 UTC
Created attachment 140704 [details] [review]
Bug 31465: (follow-up) Link to preference tabs directly

This patch enhances the mapping system for the help button to allow for
each tab of preferences to link directly to the relevent section of the
manual.
Comment 7 David Nind 2022-09-18 21:13:14 UTC
Created attachment 140739 [details] [review]
Bug 31465: Correct help link for preferences

This patch updates the mapping to reflect the split and rename of the
preferences section of the manual.

Test plan
1) Hitting 'Help' on any tab except for 'Local use' should lead you to
   the globalpreferences section of the manual for your Koha version.
2) Hitting 'Help' on the 'Local use' tab should take you directly to the
   'localusepreferences' manual page.

NOTE: I have now updated the manual build pipeline to remove
renamed/deleted files so prior to this patch you should now see a 404
response when clicking Help from these pages.  Before I made that
change, we had the old file hanging around, so you actually got an
outdated manual page disguised as a more recent version.

Signed-off-by: David Nind <david@davidnind.com>
Comment 8 David Nind 2022-09-18 21:13:18 UTC
Created attachment 140740 [details] [review]
Bug 31465: (follow-up) Link to preference tabs directly

This patch enhances the mapping system for the help button to allow for
each tab of preferences to link directly to the relevent section of the
manual.

Signed-off-by: David Nind <david@davidnind.com>
Comment 9 David Nind 2022-09-18 21:13:46 UTC
Thanks Martin!
Comment 10 Katrin Fischer 2022-09-20 20:21:35 UTC
*** Bug 2326 has been marked as a duplicate of this bug. ***
Comment 11 Katrin Fischer 2022-09-20 20:22:48 UTC
Updating description to this makes sense for the release notes :)
Comment 12 Katrin Fischer 2022-09-20 20:25:31 UTC
Created attachment 140804 [details] [review]
Bug 31465: Correct help link for preferences

This patch updates the mapping to reflect the split and rename of the
preferences section of the manual.

Test plan
1) Hitting 'Help' on any tab except for 'Local use' should lead you to
   the globalpreferences section of the manual for your Koha version.
2) Hitting 'Help' on the 'Local use' tab should take you directly to the
   'localusepreferences' manual page.

NOTE: I have now updated the manual build pipeline to remove
renamed/deleted files so prior to this patch you should now see a 404
response when clicking Help from these pages.  Before I made that
change, we had the old file hanging around, so you actually got an
outdated manual page disguised as a more recent version.

Signed-off-by: David Nind <david@davidnind.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 13 Katrin Fischer 2022-09-20 20:25:36 UTC
Created attachment 140805 [details] [review]
Bug 31465: (follow-up) Link to preference tabs directly

This patch enhances the mapping system for the help button to allow for
each tab of preferences to link directly to the relevent section of the
manual.

Signed-off-by: David Nind <david@davidnind.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 14 Martin Renvoize 2022-10-05 10:36:06 UTC
This looks like we just missed updating the status.. David SO'd and Katrin QA'd.
Comment 15 Tomás Cohen Arazi 2022-10-05 19:35:16 UTC
Pushed to master for 22.11.

Nice work everyone, thanks!
Comment 16 Nick Clemens 2022-11-10 15:55:07 UTC
*** Bug 32153 has been marked as a duplicate of this bug. ***
Comment 17 Lucas Gass 2022-11-10 23:27:06 UTC
Backported to 22.05.x for upcoming 22.05.07 release
Comment 18 Arthur Suzuki 2022-11-15 17:09:24 UTC
applied to 21.11 for 21.11.14
Comment 19 Victor Grousset/tuxayo 2022-11-27 00:06:18 UTC
Not backported to oldoldstable (21.05.x). Feel free to ask if it's needed.

Nothing to document it seems, marking resolved.