Bug 32022 - Style tweaks to fieldsets and page-section
Summary: Style tweaks to fieldsets and page-section
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: Main
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
: 31904 (view as bug list)
Depends on: 30952
Blocks:
  Show dependency treegraph
 
Reported: 2022-10-27 18:17 UTC by Owen Leonard
Modified: 2023-08-30 10:01 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.11.00


Attachments
Bug 32022: Style tweaks to fieldsets and page-section (3.12 KB, patch)
2022-10-27 18:26 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 32022: Style tweaks to fieldsets and page-section (3.18 KB, patch)
2022-10-28 07:56 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 32022: (follow-up) Ensure action background takes presidence (1.37 KB, patch)
2022-10-28 07:56 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 32022: Style tweaks to fieldsets and page-section (3.26 KB, patch)
2022-10-28 08:23 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 32022: (follow-up) Ensure action background takes presidence (1.45 KB, patch)
2022-10-28 08:24 UTC, Jonathan Druart
Details | Diff | Splinter Review
picture of form in 22.11.06 (53.66 KB, image/png)
2023-07-18 16:17 UTC, Pedro Amorim
Details
picture of form in master (55.64 KB, image/png)
2023-07-18 16:17 UTC, Pedro Amorim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2022-10-27 18:17:46 UTC
I'd like to move padding and margin-bottom into the @card mixin so that similar elements (fieldsets, page-sections) have consistent padding.

I would also like to tweak the style of fieldset.action so that it works well visually in cases where it is outside the corresponding fieldset.rows.
Comment 1 Owen Leonard 2022-10-27 18:26:10 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2022-10-27 18:54:58 UTC
*** Bug 31904 has been marked as a duplicate of this bug. ***
Comment 3 Martin Renvoize 2022-10-28 07:50:59 UTC
Generally I like the consistency here.. one minor thing I wonder a bit about.. by making the 'action' fieldset also have a white background it makes it appear like the buttons are now part of that fieldset.. I think I like the spacing but would prefer the background remain the grey so the buttons appear to be distinct but related as they did before the whole refresh?
Comment 4 Martin Renvoize 2022-10-28 07:56:17 UTC Comment hidden (obsolete)
Comment 5 Martin Renvoize 2022-10-28 07:56:21 UTC Comment hidden (obsolete)
Comment 6 Jonathan Druart 2022-10-28 08:23:57 UTC
Created attachment 142753 [details] [review]
Bug 32022: Style tweaks to fieldsets and page-section

This patch makes CSS changes to try to bring some consistency to
various elements which are similar in the general sense of "white box."
Fieldsets, page-section, etc.

To test apply the patch and rebuild the staff interface CSS.

Test various pages with page-section, fieldsets, etc.:

- Patron details
- Patron edit
- Patron accounting
- Check Tools -> Patron lists -> New to confirm that there is not a gap
  between the submit button's container and the rest of the form.

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 7 Jonathan Druart 2022-10-28 08:24:02 UTC
Created attachment 142754 [details] [review]
Bug 32022: (follow-up) Ensure action background takes presidence

The action class sets the background to transparent, but because it's
often used in conjunction with the fieldset which includes the card
mixin the background rule was getting overridden to white.

Test plan
1. Consider the same cases as the original patch
2. Confirm that the last test now shows the buttons outside of the card
   but nicely spaced to clearly belong to it.

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
Comment 8 Tomás Cohen Arazi 2022-10-28 19:48:06 UTC
Pushed to master for 22.11.

Nice work everyone, thanks!
Comment 9 Pedro Amorim 2023-07-18 16:17:24 UTC
Created attachment 153615 [details]
picture of form in 22.11.06
Comment 10 Pedro Amorim 2023-07-18 16:17:41 UTC
Created attachment 153616 [details]
picture of form in master
Comment 11 Pedro Amorim 2023-07-18 16:17:58 UTC
This made the "Submit" button very close the form, is this intentional?
Comment 12 Matt Blenkinsop 2023-07-18 16:46:31 UTC
Possible conflict with 32605? One adds a margin to .rows and the other adds it to the .action fieldset
Comment 13 Owen Leonard 2023-07-18 16:50:14 UTC
(In reply to Pedro Amorim from comment #11)
> This made the "Submit" button very close the form, is this intentional?

It's the patch for Bug 34072 that caused this. I'm trying to figure out what the original problem looked like so I can try to address the side-effect.
Comment 14 Katrin Fischer 2023-07-18 22:02:31 UTC
(In reply to Owen Leonard from comment #13)
> (In reply to Pedro Amorim from comment #11)
> > This made the "Submit" button very close the form, is this intentional?
> 
> It's the patch for Bug 34072 that caused this. I'm trying to figure out what
> the original problem looked like so I can try to address the side-effect.

Sorry for that one :( I could see the issue in testing, I didn't spot side effects but I should have looked harder.