Bug 3246 - Looking for a way to customize the patron slips (receipts)
Summary: Looking for a way to customize the patron slips (receipts)
Status: CLOSED DUPLICATE of bug 7001
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: unspecified
Hardware: PC All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: Galen Charlton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 6287
  Show dependency treegraph
 
Reported: 2009-05-22 01:44 UTC by Liz Rea
Modified: 2013-12-05 22:11 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:08:15 UTC


---- Reported by wizzyrea@gmail.com 2009-05-22 13:44:08 ----

This could be handled one of several ways, as discussed in IRC:

1. A bundle of editable sysprefs for editing the header/footer of the slips. Configurable by branch.

2. gmcharlt suggests it might be a candidate for HTML::Toolkit. I'm not sure what that means but is another way to handle it.

3. Addition of jquery framework to the moremember-receipt.tmpl so the receipt can be modified on the fly by jquery (perhaps an aside to the other two)

Discussion welcome and encouraged.



---- Additional Comments From gmcharlt@gmail.com 2009-05-22 13:47:37 ----

My suggestion was to use Template::Toolkit, not HTML::Toolkit. :)

Template::Toolkit is a Perl module for doing templating, and has a nice, simple language for the templates.  The project's website is http://template-toolkit.org/.  One tutorial to look at is

http://template-toolkit.org/docs/tutorial/Web.html



---- Additional Comments From drdrulm@yahoo.com 2009-10-23 15:52:28 ----

I sent an update for this to solve the issue of adding content (HTML) by date using the news scheduler, the HTML custom work still needs done. 

BUG #3246 Enhancement - Modify news to be able to have scheduled receipt slip messages
There are 3 files to this patch / koha-news.tmpl moremember-receipt.tmpl and moremember.pl
This file is koha-news.tmpl
This enhancement will allow the news scheduler to schedule messahes to the opac / intranet / and slips
which is useful because then ads can be presented at the bottom of receipts as well as *long-term*
custimizations since any type of code can go into these slips - one can make a long term custimization to
add information (anything/anyformat) to the bottom of the slip as well as periodic news items




---- Additional Comments From wizzyrea@gmail.com 2009-10-23 20:36:57 ----

Darrel,

This is a great idea! Great job!

Thanks!

(can't wait to get it!!!)

Liz



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:08 UTC  ---

This bug was previously known as _bug_ 3246 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3246

Actual time not defined. Setting to 0.0
The original assignee of this bug does not have
   an account here. Reassigning to the default assignee
   for the component, gmcharlt@gmail.com.
   Previous assignee was drdrulm@yahoo.com.
CC member adrea@moablibrary.org does not have an account here
CC member drdrulm@yahoo.com does not have an account here
CC member jwagner@ptfs.com does not have an account here

Comment 1 Melia Meggs 2013-01-04 23:18:31 UTC
Slips are now customizable in version 3.8 and later.

*** This bug has been marked as a duplicate of bug 7001 ***