Bug 3317 - Author displays inconsistently ( and incorrectly ) in opac-basket.pl (and when emailing cart )
Summary: Author displays inconsistently ( and incorrectly ) in opac-basket.pl (and whe...
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Garry Collum
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-09 10:05 UTC by Chris Cormack
Modified: 2020-11-30 21:44 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
cart (43.28 KB, image/png)
2009-06-22 14:53 UTC, Chris Cormack
Details
email (68.83 KB, image/png)
2009-06-22 14:53 UTC, Chris Cormack
Details
search results (84.17 KB, image/png)
2009-06-22 14:54 UTC, Chris Cormack
Details
three marc records (2.97 KB, application/zip)
2009-06-23 20:45 UTC, Chris Cormack
Details
Patch for email portion (3.55 KB, patch)
2009-06-27 18:13 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:09:04 UTC


---- Reported by rch@liblime.com 2009-06-09 22:05:34 ----

Symptoms:

Clicking 'More Details' when viewing a basket shows a blank author field.
Emailing the cart doesn't properly show author information.

Details:

opac-basket.pl gets the author(s) by calling GetMarcAuthors.
This function actually only gets additional authors from the marc record, and ignores 1XX tags.
The template then tries to access a data element ->{'value'}, which isn't returned from GetMarcAuthors().



---- Additional Comments From gmcharlt@gmail.com 2009-06-15 18:01:55 ----

Pushed Garry's patch.  Please test and close.



---- Additional Comments From gmcharlt@gmail.com 2009-06-17 16:47:02 ----

Pushed Garry's followup patch.



---- Additional Comments From nengard@gmail.com 2009-06-22 14:52:54 ----

The cart is still not displaying author properly. Authors are also wrong in the email - sometimes only displaying one author and other times showing nothing. See attached.



---- Additional Comments From nengard@gmail.com 2009-06-22 14:53:21 ----

Created an attachment
search results





---- Additional Comments From nengard@gmail.com 2009-06-22 14:53:46 ----

Created an attachment
email





---- Additional Comments From nengard@gmail.com 2009-06-22 14:54:12 ----

Created an attachment
search results





---- Additional Comments From gcollum@gmail.com 2009-06-23 02:37:20 ----

Hi Nicole,

Is it possible that you could attach a view of the marc records or your examples, or send me copies of the marc records?



---- Additional Comments From nengard@gmail.com 2009-06-23 20:45:32 ----

Created an attachment
three marc records

The marc for those three results are attached.



---- Additional Comments From gcollum@gmail.com 2009-06-24 11:53:37 ----

Thanks.  I'll see if I can duplicate the inconsistent behavior on my machine.  The email is a separate but related problem.  We just have to duplicate whatever fix is done in the code that creates the email.



---- Additional Comments From gcollum@gmail.com 2009-06-27 18:13:05 ----

Created an attachment
Patch for email portion

I've submitted a patch which will render the author and the added author fields in the email that is generated from the shopping cart.

In the default view, the brief display, only authors in an authority record display.  The added authors are visible only if you click on "more details."  Do we want all of the authors displaying on the brief display?  I don't see any reason why not other than records with a multitude of authors.

I think one point of confusion is that there are two different screen views of the shopping cart list, but there's only one email view that is generated.

The other issue is with that corporate author field in the attached Liblime record. Authority field 110 is not getting rendered, but this seems to be a more comprehensive bug than just the shopping cart.  If you turn off XSLTDetailsDisplay and XSLTResultsDisplay in Opac, the 110 field is not rendered in the regular opac results.  I wasn't able to find a but report on this, so I will open one, but I thought I would test 111 and 130 as well before I create a bug report.





---- Additional Comments From gcollum@gmail.com 2009-06-28 11:39:05 ----

Just discovered that the non-display of the 110 was a known issue, and may have been by design.

http://new.koha.org/documentation/faq/how-can-i-make-the-contents-of-field-110a-appear-as-author-in-opac-normal-view

I closed the bug that I opened. (#3373)

Is it the goal to have all bib and item data eventually rendered through xsl?



---- Additional Comments From gmcharlt@gmail.com 2009-07-15 02:59:27 ----

Patch pushed.  Please test and close.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:09 UTC  ---

This bug was previously known as _bug_ 3317 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3317
Imported an attachment (id=1216)
Imported an attachment (id=1217)
Imported an attachment (id=1218)
Imported an attachment (id=1219)
Imported an attachment (id=1220)

Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was rch@liblime.com.
The original submitter of attachment 1216 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 1217 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 1218 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 1219 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 1220 [details] [review] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Owen Leonard 2011-05-18 14:02:38 UTC
Bug still exists in master.
Comment 2 Marc Véron 2016-01-02 16:38:39 UTC
Is this bug still valid?
Comment 3 Viktor Sarge 2016-12-28 10:11:59 UTC
For what it's worth I've noticed that the brief display of the cart indeed still don't display authors all the time.
Comment 4 Owen Leonard 2019-11-19 13:00:31 UTC
I believe this issue has been fixed. If someone finds otherwise please re-open with additional details.