Bug 3345 - Return All items on patron detail does not initiate transfer of holds
Summary: Return All items on patron detail does not initiate transfer of holds
Status: CLOSED DUPLICATE of bug 3514
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: 3.4
Hardware: All All
: P5 - low critical (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-19 05:34 UTC by Liz Rea
Modified: 2019-06-27 09:24 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:09:23 UTC


---- Reported by wizzyrea@gmail.com 2009-06-19 17:34:29 ----

Example:

Library 1 has a patron who has 5 books checked out (A, B, C, D, E). We have three branches in our system(1, 2, 3).

A is an item from library 1 (the local branch) with no holds.
B is an item from library 2, with no holds.
C is an item from library 1 with a queued hold at library 2.
D is an item from library 2 with queued holds at library 3.
E is an item from library 1 with queued holds at library 1.

When all items are returned via Return All:
Item A is returned normally (ok)
Item B is returned, but transfer is initiated without staff notification (problematic, but merely annoying)
Item C is returned, but nothing happens. A transfer to fill the hold at Library 2 should be initiated, but is not. Koha checks it in and changes the current location to library 1. (very problematic)
Item D similar to item C, the item is orphaned at Library 1. (very problematic)
Item E needs more testing at this time, but wanted to get this bug submitted. Will add comment to elaborate.

</example>

Return ALL items on the patron detail page does not work well with holds/multiple branches.

Proposed ways to fix this:
RETURN ALL items presents each item in sequence to deal with individually (confirm/transfer/return home). Seems clunky.

RETURN ALL items presents all items in an ajax-y way to click click click confirm/transfer/return home). Less clunky, but still... eh.

Other ideas? I'm drawing a blank.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:09 UTC  ---

This bug was previously known as _bug_ 3345 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3345

Actual time not defined. Setting to 0.0

Comment 1 Katrin Fischer 2011-04-24 14:39:05 UTC

*** This bug has been marked as a duplicate of bug 3514 ***