Bug 3656 - Specify fields to be omitted from the patron record
Summary: Specify fields to be omitted from the patron record
Status: CLOSED DUPLICATE of bug 6190
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: rel_3_0
Hardware: PC All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Assignee: Henri-Damien LAURENT
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-23 12:58 UTC by Jane Wagner
Modified: 2012-10-26 00:40 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Adds BorrowerUnusedFields system preference and uses it. (24.42 KB, patch)
2009-09-24 08:13 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:13:22 UTC


---- Reported by jwagner@ptfs.com 2009-09-23 12:58:56 ----

I had a request from one site to remove the Street Number field from the patron address record, so that staff would be forced to use the Address field.  I was thinking about a syspref to turn on/off the Street Number field in patron edit.  After discussion on the IRC, Henri-Damien Laurent said he'd done a patch to list fields that should be omitted from patron edit, which sounds like a more comprehensive solution than a syspref just for Street Number.  He asked me to open a bug report so that he could submit that patch.

(Thanks!)



---- Additional Comments From henridamien@koha-fr.org 2009-09-24 08:13:43 ----

Created an attachment
Adds BorrowerUnusedFields system preference and uses it.





--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:13 UTC  ---

This bug was previously known as _bug_ 3656 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3656
Imported an attachment (id=1488)

Unknown operating system Windows 2000. Setting to default OS "All".
Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was jwagner@ptfs.com.
The original submitter of attachment 1488 [details] [review] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Chris Cormack 2010-12-15 07:05:31 UTC
This doesn't look like it was ever pushed, is it still needed?
Comment 2 Jane Wagner 2010-12-15 13:10:32 UTC
I'd certainly like to have it, and I think it would be extremely useful to a lot of sites.
Comment 3 Nicole C. Engard 2011-03-04 15:05:19 UTC
Does not apply anymore:



Apply? [y]es/[n]o/[e]dit/[v]iew patch/[a]ccept all y
Applying: selection of members fields to display
Using index info to reconstruct a base tree...
<stdin>:213: trailing whitespace.
    <legend>Contact</legend><ol>       
<stdin>:335: trailing whitespace.
      <!-- TMPL_UNLESS Name="unusedB_email"--><li> 
<stdin>:362: trailing whitespace.
    <!-- TMPL_UNLESS Name="unusedmemberentry_altaddress"-->     <fieldset class="rows" id="memberentry_altaddress">       
<stdin>:464: trailing whitespace.
        
<stdin>:508: trailing whitespace.
  warn $_;  
warning: 5 lines add whitespace errors.
Falling back to patching base and 3-way merge...
Auto-merging admin/systempreferences.pl
Auto-merging installer/data/mysql/en/mandatory/sysprefs.sql
CONFLICT (content): Merge conflict in installer/data/mysql/en/mandatory/sysprefs.sql
Auto-merging installer/data/mysql/fr-FR/1-Obligatoire/unimarc_standard_systemprefs.sql
CONFLICT (content): Merge conflict in installer/data/mysql/fr-FR/1-Obligatoire/unimarc_standard_systemprefs.sql
Auto-merging installer/data/mysql/updatedatabase.pl
CONFLICT (content): Merge conflict in installer/data/mysql/updatedatabase.pl
Auto-merging koha-tmpl/intranet-tmpl/prog/en/modules/members/memberentrygen.tmpl
Auto-merging members/memberentry.pl
Failed to merge in the changes.
Patch failed at 0001 selection of members fields to display
When you have resolved this problem run "git am --resolved".
If you would prefer to skip this patch, instead run "git am --skip".
To restore the original branch and stop patching run "git am --abort".
nengard@debian:~/kohaclone$
Comment 4 Katrin Fischer 2011-04-14 06:05:52 UTC

*** This bug has been marked as a duplicate of bug 6190 ***