Bug 3686 - Hold slips sometimes don't print barcode
Summary: Hold slips sometimes don't print barcode
Status: RESOLVED DUPLICATE of bug 7255
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: rel_3_0
Hardware: PC All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-01 01:47 UTC by Jane Wagner
Modified: 2012-06-26 13:52 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:13:43 UTC


---- Reported by jwagner@ptfs.com 2009-10-01 13:47:05 ----

(Not sure if this should be under circulation or holds.)

I've had reports, and I've replicated myself, of item barcodes sometimes not printing on hold slips when a hold is triggered.  At other times, the barcode will appear with no problem, and if you can do a refresh on the hold slip window, the barcode may show up.  If you cancel the print and try again, the barcode may show on the second try.  

The items definitely have barcodes.  It seems to be some kind of browser refresh or cache problem, but I don't know why it would affect only the barcode, or happen at all.  Any ideas?  Here's the source code from the same item's hold slip, first time where the barcode didn't appear, and second time after a refresh when it did appear:

<h3>RESERVED ITEM</h3>
 <h4>The hippopotamus marsh /</h4>
 <h5>Gedge, Pauline, </h5>
 <p></p>
 

<h3>RESERVED ITEM</h3>
 <h4>The hippopotamus marsh /</h4>
 <h5>Gedge, Pauline, </h5>
 <p>39344005732174</p>



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:13 UTC  ---

This bug was previously known as _bug_ 3686 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3686

Unknown operating system Windows 2000. Setting to default OS "All".
Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was jwagner@ptfs.com.

Comment 1 Albert Oller 2012-06-26 13:52:45 UTC
This looks like a dupe of http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7255

*** This bug has been marked as a duplicate of bug 7255 ***