Bug 3710 - New script for recent acquisitions
Summary: New script for recent acquisitions
Status: CLOSED WONTFIX
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low critical (vote)
Target Milestone: Oldversions
Assignee: Henri-Damien LAURENT
QA Contact: Bugs List
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2009-10-14 12:53 UTC by Nahuel Angelinetti
Modified: 2018-12-16 19:34 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
bugfix (27.86 KB, patch)
2009-10-14 13:49 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:14:04 UTC


---- Reported by nahuel.angelinetti@biblibre.com 2009-10-14 12:53:22 ----

A new script should be created to show users the recent acquisitions in opac AND intranet.



---- Additional Comments From oleonard@myacpl.org 2009-10-14 13:02:37 ----

How would this be different than doing a regular search and ordering the results by acquisition date?



---- Additional Comments From nahuel.angelinetti@biblibre.com 2009-10-14 13:49:33 ----

Created an attachment
bugfix





---- Additional Comments From nahuel.angelinetti@biblibre.com 2009-10-14 13:50:32 ----

I invite you to look my patch. 



---- Additional Comments From nengard@gmail.com 2010-02-06 23:30:14 ----

Will this make it into 3.2? Looks awesome but I don't see it right now.



---- Additional Comments From gmcharlt@gmail.com 2010-02-08 12:58:39 ----

(In reply to comment #1)
> How would this be different than doing a regular search and ordering the
> results by acquisition date?
> 

Nahuel: Owen's question is a good one - please answer.



---- Additional Comments From nengard@gmail.com 2010-02-08 13:03:42 ----

While it may not be different it's easier I think for librarians - and it's something people ask for and don't like when we say you can just do a search :)  

I'll let Nahuel answer the technical aspects of this question.



---- Additional Comments From nahuel.angelinetti@biblibre.com 2010-02-08 13:58:13 ----

Not only for librarians, but for borrowers too, I don't know if my mother is able to understand that sorting by acqdate exist, because she don't look all the interface, just what she needs.
This add a button for recent acquisition, it's a bit more user friendly, and technically this doesn't implies you have to do the right koha2marc mapping.



---- Additional Comments From gmcharlt@gmail.com 2010-02-08 14:33:47 ----

I am not inclined to push this as is.  I have no objection to adding an easier user interface to display recent purchase, nor do I have any objection to creating a syspref to allow the library to just turn on such a display with no fuss, but this patch has serious flaws:

* GetBiblioSummary - I will not push this as it stands now: we have at last count *three* systems for mapping MARC records and displaying them, none of which require hard-coding HTML and MARC tags.  To repeat: there is no excuse for hard-coding HTML in C4 routines.

* SearchAcquisitions - indexing dateaccessioned and using Zebra (or NoZebra) would suffice.  I see no reason for a new search routine.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:14 UTC  ---

This bug was previously known as _bug_ 3710 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3710
Imported an attachment (id=1533)

Actual time not defined. Setting to 0.0
The original submitter of attachment 1533 [details] [review] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Owen Leonard 2010-07-23 12:46:17 UTC
Removing "PATCH-sent" priority since the submitted patch isn't getting approved.
Comment 2 Katrin Fischer 2010-11-08 16:43:17 UTC
I think we have a problem here.

The files and the feature exist in 3.0.x, but not in 3.2:

http://git.koha-community.org/gitweb/?p=koha.git;a=commit;h=96da408353314672362440808fb7b173b03dd562

http://git.koha-community.org/gitweb/?p=koha.git;a=commit;h=5222f73de001df8fc8ec499d5507aad3651d1512

I can't test the feature, but a user was reporting problems with it on IRC today, using 3.0.5:

http://stats.workbuffer.org/irclog/koha/2010-11-08#i_534826
Comment 3 Katrin Fischer 2010-11-08 16:56:06 UTC
Repeating myself, because qa contact was missing in the bug:

I think we have a bigger problem here.
The files and the feature exist in 3.0.x, but not in 3.2.
Comment 4 Katrin Fischer 2011-08-15 19:23:51 UTC
Problem is still not resolved, there is no recent acquisitions feature in current master.
Comment 5 Katrin Fischer 2011-10-28 17:08:27 UTC
The attached patch needs to be rewritten completely for our current templating system to adapt to all the changes made since the patch was created and to solve the issues noted by Galen. 
The updatedatabase shows +$DBversion = "3.01.00.116";
I am marking this WONTFIX.