Bug 3735 - Wrong search results for a few fields in ccl.properties
Summary: Wrong search results for a few fields in ccl.properties
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) minor (vote)
Target Milestone: ---
Assignee: Marcel de Rooy
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-29 09:30 UTC by Marcel de Rooy
Modified: 2012-10-25 23:03 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Patch file (2.29 KB, patch)
2010-12-20 12:36 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Signed-off patch (2.66 KB, patch)
2011-03-17 14:39 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:14:23 UTC


---- Reported by m.de.rooy@rijksmuseum.nl 2009-10-29 09:30:55 ----

When searching "name=test", the search gives the same results as "test". The same holds for some other fields as notes, keyTitle, etc. 
This is caused by an erroneous definition in ccl.properties. See below. The first equal sign between name and 1=1002 should not be there. Commenting all of these lines is a fast bug resolver...

###################################################
# Rules for a few bath atts
keyTitle         = 1=33
possessingInstitution    = 1=1044
name             = 1=1002
personalName     = 1=1
corporateName    = 1=2
conferenceName   = 1=3
uniformTitle     = 1=6
isbn             = 1=7
issn             = 1=8
geographicName   = 1=58
notes            = 1=63
topicalSubject   = 1=1079
genreForm        = 1=1075



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:14 UTC  ---

This bug was previously known as _bug_ 3735 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3735

Unknown operating system Windows 2000. Setting to default OS "All".
Actual time not defined. Setting to 0.0
CC member jwagner@ptfs.com does not have an account here
CC member mjr@ttllp.co.uk does not have an account here

Comment 1 Fridolin SOMERS 2010-07-08 15:59:55 UTC
"isbn" is used in Search.pm FindDuplicate.
Why isn't it always "nb" ?
Comment 2 Marcel de Rooy 2010-11-15 12:51:31 UTC
I will send a patch with the following proposal after examining zebra configuration files again:

First, eliminate first equal sign in the relevant lines of ccl.properties to resolve syntax issue (see first comment).

Second, leave name, isbn, issn and notes uncommented. To make this do anything in practice, I have added these four to getIndexes in Search.pm. (Otherwise a user should always type ccl=name=searchterm..)
The longer and therefore less attractive fields (keyTitle, etc.) I commented. They did not work until now and will not either. 
Additional comment: possessingInstitution is not even in bib1.att; genreForm only relates to authority searches.

To answer the question Why is it not always nb? Well, this just gives the user more options. Until now, he could type nb= or ISBN=, we just give him the lowercase option isbn= too. Other fields are aliased too.
Comment 4 Marcel de Rooy 2010-12-20 12:36:24 UTC
Created attachment 2890 [details] [review]
Patch file

Still valid for 3c19f22f8625105715f9ba5f4fca2b0502bcd9cc. (master Dec 20, 2010)
Comment 5 Jared Camins-Esakov 2011-03-17 14:39:13 UTC
Created attachment 3343 [details] [review]
Signed-off patch
Comment 6 Chris Cormack 2011-03-17 22:20:22 UTC
Pushed, please test
Comment 7 Marcel de Rooy 2011-03-18 13:01:20 UTC
Works for me. Thanks for signoff and push.