Bug 3881 - No Page for Opac Privacy
Summary: No Page for Opac Privacy
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) blocker (vote)
Target Milestone: Oldversions
Assignee: Ian Walls
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
: 1987 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-12-09 12:42 UTC by Nicole C. Engard
Modified: 2018-12-16 19:32 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
patch (53.82 KB, patch)
2011-01-30 20:02 UTC, Nicole C. Engard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:16:12 UTC


---- Reported by nengard@gmail.com 2009-12-09 12:42:29 ----

There should be a page in the OPAC that lets the user set his/her privacy settings - but when OpacPrivacy is on or off the OPAC display is the same ... no options for the patron.  On looking at the patch it looks like only the DB change was submitted - not the new page.

------------

Nicole Engard a écrit :


    Hello all,

    Liz Rea and I were looking at the newest version of HEAD and see the
    system preference for OpacPrivacy, but turning it on doesn't seem to
    do anything.  I did some searching through the patches and only see
    the patch where the preference was added - but can't find anything
    else.  Can someone tell us how this is supposed to work?
     


yes, me, as I wrote the feature.
You're supposed to have a new page on opac, that let the user control the behaviour he want (ie: anonymize immediatly, let library choose, never anonymize my reading list)
and the anonymiser script has been modified accordingly (as well as the return.pl script, to anonymize immediatly if requested)


-- 
Paul POULAIN
http://www.biblibre.com
Expert en Logiciels Libres pour l'info-doc
Tel : (33) 4 91 81 35 08



---- Additional Comments From paul.poulain@biblibre.com 2009-12-10 17:52:03 ----

patch sent again (not tested if it applies smoothly though...)



---- Additional Comments From nengard@gmail.com 2010-02-06 15:29:14 ----

Where do I find this new page - where should it be linked from? Can you attach the patch here so we can see what it is supposed to do?



---- Additional Comments From nengard@gmail.com 2010-02-06 23:45:39 ----

I did a search in patches email to see if this patch was sent - and it's not there.



---- Additional Comments From oleonard@myacpl.org 2010-02-07 00:01:35 ----

This looks like it:

http://lists.koha.org/pipermail/koha-patches/2009-December/004973.html



---- Additional Comments From nengard@gmail.com 2010-04-23 18:26:00 ----

Any word on this? I see the patch, but I still can't get to the page and I still don't see a link to it.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:16 UTC  ---

This bug was previously known as _bug_ 3881 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3881
This bug blocked bug(s) 4426.

Actual time not defined. Setting to 0.0

Comment 1 Owen Leonard 2010-06-28 15:22:17 UTC
Removing "PATCH-sent" status since there is no sign of the opac-privacy files in HEAD
Comment 2 Nicole C. Engard 2010-07-07 22:31:19 UTC
If this isn't going to make it into 3.2 then the privacy system preference should be removed. upping to blocker - because one of these things need to be done before release.
Comment 3 Galen Charlton 2010-10-22 02:22:28 UTC
Removed OpacPrivacy syspref for 3.2.
Comment 4 Ian Walls 2011-01-28 16:59:02 UTC
Reopening this bug, as I have rebased and polished Paul's original patch, and reimplemented the opac privacy feature
Comment 5 Nicole C. Engard 2011-01-30 20:02:26 UTC
Created attachment 3033 [details] [review]
patch
Comment 6 Chris Cormack 2011-01-31 17:41:17 UTC
Pushed, please test and close
Comment 7 Nicole C. Engard 2011-01-31 19:08:45 UTC
I have tested and updated the manual.  Marking fixed.
Comment 8 Paul Poulain 2011-08-02 10:23:10 UTC
*** Bug 1987 has been marked as a duplicate of this bug. ***