Bug 3969 - Budget Search Doesn't Work
Summary: Budget Search Doesn't Work
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Bugs List
URL: cgi-bin/koha/admin/aqbudgets.pl
Whiteboard:
Keywords:
: 4992 (view as bug list)
Depends on:
Blocks: 7966
  Show dependency treegraph
 
Reported: 2009-12-19 10:38 UTC by Nicole C. Engard
Modified: 2015-12-03 22:02 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
screenshot of budget search (30.43 KB, image/png)
2011-10-28 17:51 UTC, Katrin Fischer
Details
Bug 3969: Budget search in acquisition doesn't work (string changes) (4.00 KB, patch)
2012-04-14 18:35 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 3969: Budget search in acquisition does't work (search) (2.97 KB, patch)
2012-04-14 18:35 UTC, Katrin Fischer
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 3969: Budget search in acquisition doesn't work (string changes) (4.11 KB, patch)
2012-04-14 23:00 UTC, Nicole C. Engard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 3969: Budget search in acquisition does't work (search) (3.07 KB, patch)
2012-04-14 23:02 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Bug 3969: Fix funds search (4.20 KB, patch)
2015-03-24 16:33 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 3969: Fix funds search (4.21 KB, patch)
2015-03-25 08:18 UTC, Jonathan Druart
Details | Diff | Splinter Review
[Signed-off] Bug 3969: Fix funds search (4.41 KB, patch)
2015-03-25 10:23 UTC, Marc Véron
Details | Diff | Splinter Review
[PASSED QA] Bug 3969: Fix funds search (4.53 KB, patch)
2015-03-25 21:47 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:21:35 UTC


---- Reported by nengard@gmail.com 2009-12-19 22:38:01 ----

At the top of the budgets page there is a search budgets box - no matter what I enter I get just a list of the budgets that were on the screen before searching.



---- Additional Comments From nengard@gmail.com 2010-02-03 18:07:23 ----

This still doesn't work in the newest Head and I'm wondering what it is supposed to search - Root Budgets or Budgets - or both?



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:21 UTC  ---

This bug was previously known as _bug_ 3969 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3969

Actual time not defined. Setting to 0.0
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.

Comment 1 Nicole C. Engard 2010-06-02 12:01:30 UTC
I think the search box is working, but there needs to be a 'no results found' page if nothing is found - instead it looks like it just doesn't change the page
Comment 2 Katrin Fischer 2011-04-19 13:13:40 UTC
I tested this on current master .

I have 2 budgets:

- Etat 2011
- Funds testing

In this sequence.

1) When I search for "Funds testing" I end up in "Etat 2011"
2) When I search for nothing, it doesn't bring up all budgets like in other places in Koha, but nothing happens.
3) When I search for nonsense like 'agaögha' nothing happens.

It's very confusing.
Comment 3 Katrin Fischer 2011-10-28 17:51:34 UTC
Created attachment 6100 [details]
screenshot of budget search

Retesting this on current master/3.6

1) UNCLEAR: The library pull down on top is empty for me on the budget start page. When I go to the list of funds for a budget, it shows my own library in addition to an empty value. I have added a fund for another library, restricted to none, but this library still does not show up in the pull down.

2) BUG: A search for '2011' from the start page only shows my funds for budget 'Oktober 2011'. September is ignored completely. Marking it active didn't change that. 

3) BUG: A search for 'September' from the budget page shows my 'Oktober' funds?

4) BUG: A search from the 'September 2011' fund page for '2011' and 'Okober' does not work. I should bring me back to the Oktober funds list, but the page stays on the September funds.

So this seems to be still totally broken.
Bug was filed 2009-12-19 22:38:01 :(
Comment 4 Katrin Fischer 2011-10-29 13:43:05 UTC
*** Bug 4992 has been marked as a duplicate of this bug. ***
Comment 5 Katrin Fischer 2012-04-14 16:01:55 UTC
This bug is almost 2 years old now and still the budget search is unusable.
Comment 6 Katrin Fischer 2012-04-14 18:35:12 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2012-04-14 18:35:18 UTC Comment hidden (obsolete)
Comment 8 Nicole C. Engard 2012-04-14 23:00:28 UTC Comment hidden (obsolete)
Comment 9 Nicole C. Engard 2012-04-14 23:02:33 UTC Comment hidden (obsolete)
Comment 10 Nicole C. Engard 2012-04-14 23:03:35 UTC
Both patches appear to work as explained. One thing I'm not sure about (but it's not stopping me from signing off since this is way better than it was when it didn't work at all) is why when I'm logged in as superlibrarian I can't search funds for branches other than the one I'm signed in at.

Nicole
Comment 11 Katrin Fischer 2012-04-15 06:40:11 UTC
Hi Nicole,
thx for signing off :) I wondered about the list of libraries too and I agree that it should show all libraries for a super librarian. Perhaps a separate bug?
Comment 12 Nicole C. Engard 2012-04-15 23:45:10 UTC
Will do
Comment 13 Ian Walls 2012-04-16 14:49:56 UTC
First patch introduces string changes, and since we're after string freeze, this will need the RM's blessing.  But, from a QA standpoint, it's fine, it's just template-level spacing and those few string changes.

Second patch "(search)": moves param definition above action, so it gets processed.  Cleans up some spacing, and provides some conditional checks on data before acting on it (to silence warns).  Marking Passed QA.
Comment 14 Katrin Fischer 2012-04-16 14:57:07 UTC
That's why I kept string changes and functional fix in different patches - so we could patch the search, making it work. The label woudl still be wrong, but it would work. With the second patch, people would also know how to use it, but that coudl be pushed for 3.8.1.
Comment 15 Paul Poulain 2012-04-20 15:01:01 UTC
Comment on attachment 9203 [details] [review]
[SIGNED-OFF] Bug 3969: Budget search in acquisition does't work (search)

This patch has been pushed, with a follow-up: the field name is budget_name, not name.
The filter on budget name was not working correctly (the search on budget code was)

Keeping "passed QA" to push the bug with string changes after 3.8.0 release
Comment 16 Paul Poulain 2012-05-07 19:50:48 UTC
Patch pushed, but when testing it, i've found a bug : in aqbudgetperiod, the branch list is always empty. Seems the branches are loaded only in aqbudgets.pl

Will mark patch pushed, but keep the bug open
Comment 17 Katrin Fischer 2013-04-14 08:57:00 UTC
The pull down is still empty on current master.
Comment 18 Owen Leonard 2014-07-10 18:50:45 UTC
This bug appears to be valid in current master. Searching doesn't appear to work and the library selection dropdown is empty.
Comment 19 Jonathan Druart 2015-03-24 16:33:45 UTC Comment hidden (obsolete)
Comment 20 Nicole C. Engard 2015-03-24 16:51:07 UTC
When you visit the planning page you get this error:


Software error:

syntax error at /home/nengard/kohaclone/admin/aqplan.pl line 420, near "@hide_cols
    branchloop"
Execution of /home/nengard/kohaclone/admin/aqplan.pl aborted due to compilation errors.

For help, please send mail to the webmaster (webmaster@koha-vm), giving this error message and the time and date of the error.
Comment 21 Jonathan Druart 2015-03-25 08:18:37 UTC Comment hidden (obsolete)
Comment 22 Jonathan Druart 2015-03-25 08:19:19 UTC
(In reply to Nicole C. Engard from comment #20)
> When you visit the planning page you get this error:

Sorry Nicole!
I amended my patch with a last minute change, never a good idea...
Comment 23 Marc Véron 2015-03-25 10:23:47 UTC Comment hidden (obsolete)
Comment 24 Katrin Fischer 2015-03-25 21:47:14 UTC
Created attachment 37250 [details] [review]
[PASSED QA] Bug 3969: Fix funds search

The funds search does not work at all.
On the budget and the budget plan page, the library dropdown list is
empty.

Test plan:
On the budget, the budget plan and the fund pages, confirm that you are
able to search a fund by code (or name) and the library dropdown list is
correctly filled.

Tested with several combinations. Works as expected.
Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Tested various combinations, no problems found.
Passes tests and QA script.
Comment 25 Tomás Cohen Arazi 2015-03-31 14:01:43 UTC
Patches pushed to master.

Thanks Jonathan!
Comment 26 Chris Cormack 2015-04-02 20:21:55 UTC
Pushed to 3.18.x will be in 3.18.6