Bug 4019 - Lists Merge Issues
Summary: Lists Merge Issues
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Lists (show other bugs)
Version: master
Hardware: PC All
: PATCH-Sent (DO NOT USE) critical (vote)
Assignee: Henri-Damien LAURENT
QA Contact:
URL: cgi-bin/koha/virtualshelves/merge.pl?...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-30 03:36 UTC by Nicole C. Engard
Modified: 2012-10-25 22:52 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
[PATCH] BZ4019 : Lists Merge Issue (4.66 KB, patch)
2009-12-31 10:47 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:22:11 UTC


---- Reported by nengard@gmail.com 2009-12-30 15:36:32 ----

When clicking the Merge Button on a private list on the staff client I get a 500 error - marking blocker since the feature doesn't work at all.



---- Additional Comments From nengard@gmail.com 2009-12-30 15:38:33 ----

This from my error log:


[Wed Dec 30 05:39:46 2009] [error] [client 10.0.2.2] Can't locate Devel/SimpleTrace.pm in @INC (@INC contains: /home/nengard/kohaclone /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at /home/nengard/kohaclone/virtualshelves/merge.pl line 6., referer: http://localhost:8080/cgi-bin/koha/virtualshelves/shelves.pl?display=privateshelves
[Wed Dec 30 05:39:46 2009] [error] [client 10.0.2.2] BEGIN failed--compilation aborted at /home/nengard/kohaclone/virtualshelves/merge.pl line 6., referer: http://localhost:8080/cgi-bin/koha/virtualshelves/shelves.pl?display=privateshelves
[Wed Dec 30 05:39:46 2009] [error] [client 10.0.2.2] Premature end of script headers: merge.pl, referer: http://localhost:8080/cgi-bin/koha/virtualshelves/shelves.pl?display=privateshelves



---- Additional Comments From nengard@gmail.com 2009-12-30 15:55:33 ----

More info:

CHAT:

[10:38]  <nengard> see http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4019
[10:38]  <munin> Bug http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4019 blocker, P5, ---, henridamien@koha-fr.org, NEW, Lists Merge Button Throws Error
[10:38]  <owen> nengard: I found that error in my log
[10:39]  <nengard> ahhhh! got it
[10:39]  <owen> hdl_laptop: I am in debug level 2, but the error was not output to the browser
[10:40]  * owen says sternly, "Gentlemen, we are now at DebLev 2. Get to your bunkers."
[10:41]  <nengard> hehe
[10:41]  <nengard> i put my error log info into the bug report
[10:41]  <nengard> if that helps
[10:42]  * davi has quit (Remote host closed the connection)
[10:42]  <hdl_laptop> nengard: owen can you try installing Devel::SimpleTrace ?
[10:42]  <hdl_laptop> I shall ask my folks to remove that dependency
[10:43]  <nengard> doing it now
[10:44]  <owen> Okay, now I don't get an error, but I get a page filled with a huge table and this at the top: "d4d89865f7169b3e107cfe4fb00d8d00"
[10:45]  <owen> hdl_laptop: This is a tool for merging records?
[10:47]  <hdl_laptop> owen: yes.
[10:48]  <hdl_laptop> strange.
[10:48]  <hdl_laptop> You must have a merge problem.
[10:50]  <owen> hdl_laptop: I'm viewing the list of all my lists, and clicking the "merge" button for one of them.
[10:50]  <nengard> hdl_laptop owen - i get a new error now that i have that installed
[10:50]  <nengard> GET LOST ? at /home/nengard/kohaclone/virtualshelves/merge.pl line 131.
[10:50]  <owen> If I click through to one of the lists instead and "merge selected," I get an intermediary page which asks me to choose a merge reference.
[10:51]  <nengard> maybe cause my list is empty - but that means we should limit when the merge button shows -- off to add to the list
[10:51]  <owen> "get lost!" geeze nengard, can't a merge get a little privacy around here?
[10:52]  <nengard> okay - added things ot the list and it worked
[10:52]  <nengard> but now i have no idea what to do or how to document it :) 
[10:52]  <owen> What worked nengard?
[10:52]  <nengard> adding items to the list :)
[10:52]  <nengard> it was a list with 0 items
[10:53]  <nengard> and yes owen - i too see the differences between the two merge buttons
[10:53]  <nengard> the behavior of them
[10:54]  <owen> hdl_laptop: One button takes me to virtualshelves/merge.pl and the other takes me to cataloguing/merge.pl
[10:55]  <nengard> hmm
[10:55]  <nengard> yeah the cataloguing/merge tool looks a lot easier to figure out 



---- Additional Comments From nengard@gmail.com 2009-12-30 16:06:33 ----

Update:

[11:07]  <hdl_laptop> nengard: virtualshelves/merge.pl should be removed.
[11:07]  <hdl_laptop> It is obsolete.
[11:07]  <nengard> okay
[11:07]  <hdl_laptop> cataloguing/merge is the one.



---- Additional Comments From nengard@gmail.com 2009-12-30 16:08:05 ----

Summary:

1 - remove Devel::SimpleTrace dependency
2 - Remove Merge Button on lists page if the list has <2 items
3 - change link on lists page to cataloguing/merge.pl -- virtualshelves/merge.pl is obsolete



---- Additional Comments From matthias.meusburger@biblibre.com 2009-12-31 10:47:12 ----

Created an attachment
[PATCH] BZ4019 : Lists Merge Issue

Removes deprecated virtualshelves/merge.pl as well as the link to it.
Records merging is done by selecting two records from a list's content.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:22 UTC  ---

This bug was previously known as _bug_ 4019 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4019
Imported an attachment (id=1781)

Actual time not defined. Setting to 0.0
The original submitter of attachment 1781 [details] [review] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.