Bug 4161 - When adding Vendor default to active currencies
Summary: When adding Vendor default to active currencies
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: 3.8
Hardware: PC All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Target Milestone: ---
Assignee: Katrin Fischer
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
: 4970 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-02-11 02:05 UTC by Colin Campbell
Modified: 2012-10-25 23:09 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 4161: Preselect active currency for new vendors (2.06 KB, patch)
2011-10-24 16:40 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 4161: Preselect active currency for new vendors (2.18 KB, patch)
2011-10-28 16:58 UTC, Liz Rea
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:23:51 UTC


---- Reported by colin.campbell@ptfs-europe.com 2010-02-11 14:05:36 ----

Currency dropdown is in alpha order. In vendor add it would be an improvement in useability if we defaulted to the active currency



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:23 UTC  ---

This bug was previously known as _bug_ 4161 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4161

Actual time not defined. Setting to 0.0
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.

Comment 1 Katrin Fischer 2011-04-04 09:08:37 UTC
*** Bug 4970 has been marked as a duplicate of this bug. ***
Comment 2 Katrin Fischer 2011-10-24 14:42:00 UTC
This is still an annoying problem in version 3.6
Comment 3 Katrin Fischer 2011-10-24 16:40:26 UTC Comment hidden (obsolete)
Comment 4 Liz Rea 2011-10-28 16:58:20 UTC
Created attachment 6096 [details] [review]
Bug 4161: Preselect active currency for new vendors

Currently when creating a new vendor in acquisitions the alphabetical first
currency will be preselected. For better usability and less mistakes the
active curency should be preselected.

To test:
Check your currency settings in administration.
Your active currency should not be the first in the list.

1) Create a new vendor
Verify the active currency is selected for list and invoice prices.

2) Check vendor summary page
Verify the correct currencies from the vendor record are shown here.

3) Edit vendor
Verify the correct currencies from the vendor record  are shown here.

Signed-off-by: Liz Rea <lrea@nekls.org>
Verified with tests 1, 2, and 3.
Comment 5 Ian Walls 2011-11-15 17:31:34 UTC
Easy to read change, affects the supplier page only, and provides fallback to default currency.  Test plan is very clear, and verified.  Marking as Passed QA
Comment 6 Paul Poulain 2011-11-16 16:47:36 UTC
small enhancement pushed, please test
Comment 7 Marc Véron 2012-03-24 09:18:24 UTC
Tested with Koha version: 3.07.00.028

Behaves as expected.