Bug 4177 - opaccloud missing from the system preferences interface
Summary: opaccloud missing from the system preferences interface
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: System Administration (show other bugs)
Version: 3.8
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Mirko Tietgen
QA Contact: Jonathan Druart
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-13 11:06 UTC by Nicole C. Engard
Modified: 2013-12-05 20:01 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 4177 opaccloud missing from the system preferences interface (1.32 KB, patch)
2012-10-04 11:31 UTC, Mirko Tietgen
Details | Diff | Splinter Review
Bug 4177 opaccloud missing from the system preferences interface (1.46 KB, patch)
2012-10-05 13:11 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:24:02 UTC


---- Reported by nengard@gmail.com 2010-02-13 23:06:17 ----

Both OpacBrowser & OpacCloud are missing from the sys prefs interface.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:24 UTC  ---

This bug was previously known as _bug_ 4177 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4177

Actual time not defined. Setting to 0.0
The original assignee of this bug does not have
   an account here. Reassigning to the default assignee
   for the component, gmcharlt@gmail.com.
   Previous assignee was pianohacker@gmail.com.

Comment 1 Owen Leonard 2011-08-23 18:37:45 UTC
OpacBrowser appears now. Still no OpacCloud. Is that feature still functional?
Comment 2 Marc Véron 2012-09-25 07:36:08 UTC
I find the following in prog\en\modules\admin\preferences\opac.pref:

#        -
#            This system preference does not actually affect anything
#            - pref: OpacBrowser
#              choices:
#                  yes: Show
#                  no: "Don't show"
#            - a subject browser on the OPAC (generated using <code>misc/cronjobs/build_browser_and_cloud.pl</code>).
#        -
#            opac-tags_subject.pl is the only script affected by this, and it is not linked to by any other page
#            - pref: OpacCloud
#              choices:
#            - If ON, enables subject cloud on OPAC


At an other place, OpacBrowser is re-implemented, the appropriate lines can be deleted here.

Regarding OpacCloud:
If I activate the syspref (restoring missing choices) and set the preference to "ON", I get an additional menu item and text as follows:

---------------
Subject cloud

Note: This feature only available to French catalogs where ISBD subjects have been populated, and an index built by separate script.
---------------

I find additional references to OpacCloud in:

admin\systempreferences.pl
installer\data\mysql\sysprefs.sql
installer\data\mysql\update22to30.pl
C4\Auth.pm
koha-tmpl\opac-tmpl\ccsr\en\includes\masthead.inc

Questions remain:

Is that feature still functional?
Dead code? 
To be removed?
Comment 3 Mirko Tietgen 2012-09-25 09:08:12 UTC
I have been using the Opaccloud before, it needed some fiddling but worked. It's been a while ago, have not looked into using it with 3.8 yet but was planning on using this eventually.
Comment 4 Katrin Fischer 2012-09-25 10:08:02 UTC
We got it working in the past too - I am against removing it. I think keeping it out of the standard feature set (system preferences) is ok for now.
Comment 5 Mirko Tietgen 2012-10-04 11:31:31 UTC Comment hidden (obsolete)
Comment 6 Mirko Tietgen 2012-10-04 11:37:41 UTC
Added the option to the admin interface. Does not touch the actual feature.
Comment 7 Mirko Tietgen 2012-10-04 13:03:41 UTC
The feature works as intended when enabled and the script related to this feature has been run.
Comment 8 Kyle M Hall 2012-10-05 13:11:40 UTC
Created attachment 12703 [details] [review]
Bug 4177 opaccloud missing from the system preferences interface

There is no option to toggle the (existing) syspref OpacCloud. This patch adds one.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Inserted tags manually, enabled system preference, tag subject cloud displays nicely.
Comment 9 Jonathan Druart 2012-10-18 14:27:35 UTC
The patch adds a missing pref in the .pref file.
Marked as Passed QA.
Comment 10 Paul Poulain 2012-10-19 15:52:55 UTC
Patch pushed to master
Comment 11 Chris Cormack 2012-10-22 04:09:07 UTC
String changes, held for 3.8.7
Comment 12 Chris Cormack 2012-10-22 21:39:54 UTC
Pushed to 3.8.x, will be in 3.8.7
Comment 13 Liz Rea 2012-11-15 20:32:06 UTC
pushed to 3.6, will be in 3.6.11