Bug 4329 - OPAC search by shelving location option
Summary: OPAC search by shelving location option
Status: CLOSED DUPLICATE of bug 7031
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: PC All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Assignee: Ian Walls
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-22 05:50 UTC by Jane Wagner
Modified: 2012-10-26 00:40 UTC (History)
4 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
screen shot of OPAC shelving location search (32.45 KB, image/jpeg)
2010-03-22 17:50 UTC, Chris Cormack
Details
screen shot of OPAC shelving location search, revised (39.73 KB, image/jpeg)
2010-04-01 12:51 UTC, Chris Cormack
Details
patch file against current head (4.21 KB, patch)
2010-04-01 13:07 UTC, Chris Cormack
Details | Diff | Splinter Review
signed off patch (4.40 KB, patch)
2011-01-05 15:54 UTC, Nicole C. Engard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:25:54 UTC


---- Reported by jwagner@ptfs.com 2010-03-22 17:50:22 ----

Created an attachment
screen shot of OPAC shelving location search

Sponsored by Arcadia University.

The OPAC can search by item type or collection code, but not by shelving location.  This enhancement adds a shelving location search, under More Options.  Since some sites do not use shelving locations, I debated controlling it by a syspref, but decided not to.  If a site wants to hide the search option, inserting this into opacuserjs will do so:

$(document).ready(function(){ 
$("#advsearch #advsearch-shelvingloc").remove();
});



---- Additional Comments From jwagner@ptfs.com 2010-04-01 12:51:32 ----

Created an attachment
screen shot of OPAC shelving location search, revised

Revised screen shot to show stylesheet formatting (matching item type search section)




---- Additional Comments From jwagner@ptfs.com 2010-04-01 13:07:13 ----

Created an attachment
patch file against current head

patch file sent April 1, 2010.




---- Additional Comments From jwagner@ptfs.com 2010-05-12 14:02:32 ----

The fix for this bug (in ptfs-harley) can be pulled from the public git repository at http://github.com/Koha-PTFS, branch http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4329




--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:25 UTC  ---

This bug was previously known as _bug_ 4329 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4329
Imported an attachment (id=2014)
Imported an attachment (id=2015)
Imported an attachment (id=2016)

Unknown operating system Windows 2000. Setting to default OS "All".
Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was jwagner@ptfs.com.
The original assignee of this bug does not have
   an account here. Reassigning to the default assignee
   for the component, chris@bigballofwax.co.nz.
   Previous assignee was jwagner@ptfs.com.
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.
Bug reassigned, setting status to "NEW".
   Previous status was "ASSIGNED".
The original submitter of attachment 2014 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 2015 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 2016 [details] [review] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Owen Leonard 2010-12-15 16:56:41 UTC
A basic search by shelving location seems to work fine. However, when I combine a shelving location limit with an itemtype limit the results are not as I expect. I would think it would do a search for items with my selected itemtype AND my shelving location. Instead it does OR: "mc-itype:DVD or mc-loc:DISPLAY"

In my opinion this is incorrect.
Comment 2 Jane Wagner 2010-12-15 17:38:10 UTC
I've been looking at the code, but I can't see where it decides between AND and OR.  Somehow it knows to AND e.g. keyword and item types.  How do I tell it to also AND shelving location search?
Comment 3 Nicole C. Engard 2011-01-05 15:54:34 UTC
Created attachment 2950 [details] [review]
signed off patch
Comment 4 Chris Cormack 2011-01-05 20:12:14 UTC
Apply? [y]es/[n]o/[e]dit/[v]iew patch/[a]ccept all y
Applying: Bug 4329: OPAC search by shelving location
error: short SHA1 ec77493 is ambiguous.
fatal: sha1 information is lacking or useless (koha-tmpl/opac-tmpl/prog/en/modules/opac-advsearch.tmpl).
Repository lacks necessary blobs to fall back on 3-way merge.
Cannot fall back to three-way merge.
Patch failed at 0001 Bug 4329: OPAC search by shelving location
Comment 5 Nicole C. Engard 2011-01-05 20:17:56 UTC
Hmmm, applied for me, will try again.
Comment 6 Nicole C. Engard 2011-01-05 20:21:49 UTC
Chris, did you use the signed off patch? I just did it again against head and got:

Apply? [y]es/[n]o/[e]dit/[v]iew patch/[a]ccept all y
Applying Bug 4329: OPAC search by shelving location
nengard@debian:~/kohaclone$ 

It applied
Comment 7 Chris Cormack 2011-01-05 22:35:48 UTC
Yes i did the signed off one from the mailing list will try again after the meeting
Comment 8 MJ Ray (software.coop) 2011-02-01 09:20:19 UTC
This bug is mentioned in:
Bug 4329: OPAC search by	shelving location http://lists.koha-community.org/pipermail/koha-patches/2011-January/013518.html
Comment 9 Nicole C. Engard 2011-02-15 14:00:48 UTC
Chris, do I need to try this again?
Comment 10 Nicole C. Engard 2011-04-19 15:13:01 UTC
This needs a new patch because the old one edited the tmpl files.
Comment 11 Ian Walls 2011-10-14 16:47:22 UTC
I have submitted a more robust enhancement request (7031) that obsoletes this particular feature.  Marking as a duplicate.

*** This bug has been marked as a duplicate of bug 7031 ***