Bug 4338 - Consistent Interface To Currency
Summary: Consistent Interface To Currency
Status: RESOLVED DUPLICATE of bug 15084
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-24 10:32 UTC by Colin Campbell
Modified: 2016-06-19 22:16 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:26:00 UTC


---- Reported by colin.campbell@ptfs-europe.com 2010-03-24 10:32:45 ----

Currencies are currently retrieved via routines in Budgets, created and modified by routines in admin/currency.pl. There are a number of issues to be addressed ib various bug entries.

All currency manipulation routines should be in one class and a consistent interface provided. Implementation should follow best practice (see Currency routines on CPAN)

Probably for 3.4



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:26 UTC  ---

This bug was previously known as _bug_ 4338 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4338

Actual time not defined. Setting to 0.0
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.

Comment 1 Marc Véron 2016-01-05 15:44:20 UTC
Is this bug still necessary?
Comment 2 Katrin Fischer 2016-01-10 21:54:35 UTC
I think some of the problems have probably been addressed by the tax rewrite. This is a really old bug and there are no other bugs dependent on it. I think we will need more specific information about remaining issues to continue here.
Comment 3 Katrin Fischer 2016-06-19 22:16:52 UTC
We now got Koha::Currency - so I think best to move new discussion there.

*** This bug has been marked as a duplicate of bug 15084 ***