Bug 4406 - koha-zebra-ctl.sh missing LSB information
Summary: koha-zebra-ctl.sh missing LSB information
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (command-line installer) (show other bugs)
Version: unspecified
Hardware: PC All
: PATCH-Sent (DO NOT USE) trivial (vote)
Assignee: MJ Ray (software.coop)
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-26 03:49 UTC by Jared Camins
Modified: 2013-02-15 19:41 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Added LSB information and copyright headers to two scripts in misc/bin. Thanks to Mahesh T Pai <paivakil@gmail.com> for the mailing list post Message-ID: <87y60x10de.fsf@gmail.com> containing them. (3.05 KB, patch)
2011-06-20 17:02 UTC, MJ Ray (software.coop)
Details | Diff | Splinter Review
Signed-off patch (3.12 KB, patch)
2011-06-21 07:31 UTC, Magnus Enger
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:26:48 UTC


---- Reported by camins@numismatics.org 2010-04-26 15:49:21 ----

Under Debian Lenny, running update-rc.d per the instructions result in a warning. I believe the problem is lack of runtime dependency information, but it might also be that the script does not support the status and force-reload commands. Everything seems to work fine even with the warning, however. Output is below.

$ sudo update-rc.d koha-zebra-daemon defaults
update-rc.d: warning: /etc/init.d/koha-zebra-daemon missing LSB information
update-rc.d: see <http://wiki.debian.org/LSBInitScripts>
 Adding system startup for /etc/init.d/koha-zebra-daemon ...
   /etc/rc0.d/K20koha-zebra-daemon -> ../init.d/koha-zebra-daemon
   /etc/rc1.d/K20koha-zebra-daemon -> ../init.d/koha-zebra-daemon
   /etc/rc6.d/K20koha-zebra-daemon -> ../init.d/koha-zebra-daemon
   /etc/rc2.d/S20koha-zebra-daemon -> ../init.d/koha-zebra-daemon
   /etc/rc3.d/S20koha-zebra-daemon -> ../init.d/koha-zebra-daemon
   /etc/rc4.d/S20koha-zebra-daemon -> ../init.d/koha-zebra-daemon
   /etc/rc5.d/S20koha-zebra-daemon -> ../init.d/koha-zebra-daemon



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:26 UTC  ---

This bug was previously known as _bug_ 4406 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4406

Unknown operating system Linux - Debian. Setting to default OS "All".
Actual time not defined. Setting to 0.0
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.

Comment 1 MJ Ray (software.coop) 2011-06-20 17:02:47 UTC Comment hidden (obsolete)
Comment 2 Magnus Enger 2011-06-21 07:31:43 UTC
Created attachment 4513 [details] [review]
Signed-off patch

After applying the patch (and doing an upgrade, on a dev install), the warning no longer appears: 

$ sudo ln -s /home/magnus/sites/kohanor32-dev/bin/koha-zebra-ctl.sh /etc/init.d/koha-zebra-daemon
$ sudo update-rc.d koha-zebra-daemon defaults
 Adding system startup for /etc/init.d/koha-zebra-daemon ...
   /etc/rc0.d/K20koha-zebra-daemon -> ../init.d/koha-zebra-daemon
   /etc/rc1.d/K20koha-zebra-daemon -> ../init.d/koha-zebra-daemon
   /etc/rc6.d/K20koha-zebra-daemon -> ../init.d/koha-zebra-daemon
   /etc/rc2.d/S20koha-zebra-daemon -> ../init.d/koha-zebra-daemon
   /etc/rc3.d/S20koha-zebra-daemon -> ../init.d/koha-zebra-daemon
   /etc/rc4.d/S20koha-zebra-daemon -> ../init.d/koha-zebra-daemon
   /etc/rc5.d/S20koha-zebra-daemon -> ../init.d/koha-zebra-daemon

Signing off!
Comment 3 Chris Cormack 2011-06-25 14:45:56 UTC
Pushed to master please test