Bug 4481 - Search's Limit to Available filters out many available items
Summary: Search's Limit to Available filters out many available items
Status: RESOLVED DUPLICATE of bug 7031
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P1 - high major (vote)
Assignee: Ian Walls
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 9234
  Show dependency treegraph
 
Reported: 2010-05-10 05:43 UTC by Ian Walls
Modified: 2013-10-05 01:28 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
bugfix for bug 4481 (2.13 KB, patch)
2010-05-18 22:13 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:27:41 UTC


---- Reported by ian.walls@bywatersolutions.com 2010-05-10 17:43:53 ----

As discussed in the Listserv thread: http://lists.katipo.co.nz/pipermail/koha/2010-May/023776.html

When limiting a search to only display available items, numerous items that are available and returned in the unfiltered search are not return in the filtered one.

This is still the case after running /misc/migration_tools/fix_onloan.pl, and making sure items.onloan is null rather than "0000-00-00".

This problem appears to have started with commit 3daa3143 on Nov. 9, 2009.



---- Additional Comments From ian.walls@bywatersolutions.com 2010-05-18 22:13:08 ----

Created an attachment
bugfix for http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4481





--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:27 UTC  ---

This bug was previously known as _bug_ 4481 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4481
Imported an attachment (id=2125)

Actual time not defined. Setting to 0.0
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.
The original submitter of attachment 2125 [details] [review] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Frédéric Demians 2010-08-25 08:14:22 UTC
I confirm this bug, Ian suspicion and Chris patch.

Chris patch works for MARC21 and doesn't for UNIMARC. Even if UNIMARC seems to have onload and lost indexes.
Comment 2 Nicole C. Engard 2011-06-09 16:35:09 UTC
since the patch has been sent and did now work for all marc formats I'm updating the statuses here.
Comment 3 Magnus Enger 2012-10-29 09:40:55 UTC
If the patch from Chris makes things better for MARC21 and not any worse for UNIMARC, maybe it could be pushed, even if it does not help UNIMARC?
Comment 4 Katrin Fischer 2012-10-29 09:45:02 UTC
This is a long standing problem - I agree with Magnus that a fix for one MARC format would be better than leaving it broken for all.
Comment 5 Kyle M Hall 2012-11-02 13:08:21 UTC
Can anyone post a test plan to replicate the bug and test it?

It appears that Frédéric has already tested and confirmed that it works for MARC21. Is that good enough to mark it signed-off?
Comment 6 Owen Leonard 2012-11-12 14:02:34 UTC
This doesn't apply anymore. I second the call for a test plan.
Comment 7 Mason James 2012-11-13 03:55:14 UTC
(In reply to comment #4)
> This is a long standing problem - I agree with Magnus that a fix for one
> MARC format would be better than leaving it broken for all.


im going to increase the severity of this bug - please change it, if you are offended
Comment 8 Chris Cormack 2013-10-05 01:28:32 UTC
This was fixed by 7031

*** This bug has been marked as a duplicate of bug 7031 ***