Bug 4529 - columns on circ history all screwy
Summary: columns on circ history all screwy
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) major (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL: cgi-bin/koha/catalogue/issuehistory.p...
Keywords:
: 2570 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-05-19 01:52 UTC by Nicole C. Engard
Modified: 2012-10-25 22:52 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
bib circ history (59.39 KB, image/png)
2010-05-19 01:52 UTC, Chris Cormack
Details
Proposed fix (5.38 KB, patch)
2010-05-19 13:44 UTC, Chris Cormack
Details | Diff | Splinter Review
Proposed fix, corrected (5.39 KB, patch)
2010-05-19 13:47 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:28:15 UTC


---- Reported by nengard@gmail.com 2010-05-19 01:52:27 ----

Created an attachment
bib circ history

Yes, screwy is a technical term :)

Anyway, see attached.  On the circ history tab on the bib record you will see that the column headings do not match up with the data in the table.



---- Additional Comments From oleonard@myacpl.org 2010-05-19 13:44:22 ----

Created an attachment
Proposed fix

Included changes:
    - fix formatting of last renew date
    - Add table zebra striping
    - Other markup structure changes
    - Revised template assumes that issues.branchcode == checkout library and displays that value instead of issues.issuingbranch (which is always empty, see http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=2806) issues.branchcode seems to reflect the item's holding branch *after* having been updated as part of the checkout transaction.



---- Additional Comments From oleonard@myacpl.org 2010-05-19 13:47:03 ----

Created an attachment
Proposed fix, corrected

Grammar correction.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:28 UTC  ---

This bug was previously known as _bug_ 4529 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4529
This bug depended on bug(s) 2570.
Imported an attachment (id=2144)
Imported an attachment (id=2145)
Imported an attachment (id=2146)

Actual time not defined. Setting to 0.0
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.
The original submitter of attachment 2144 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 2145 [details] [review] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 2146 [details] [review] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Galen Charlton 2010-05-24 14:46:22 UTC
*** Bug 2570 has been marked as a duplicate of this bug. ***
Comment 2 Galen Charlton 2010-05-24 14:47:21 UTC
Pushed Owen's patch to HEAD.  Please test and close.  Please note that Ian's patch for 2570 no longer appears needed.