Bug 4907 - Suggestions "organize by" menu doesn't reflect current choice
Summary: Suggestions "organize by" menu doesn't reflect current choice
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Target Milestone: ---
Assignee: Katrin Fischer
QA Contact: Bugs List
URL: /cgi-bin/koha/suggestion/suggestion.pl
Whiteboard:
Keywords:
: 9318 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-24 16:44 UTC by Owen Leonard
Modified: 2014-12-07 20:03 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 4907: 'Organize by' filter in suggestions doesn't reflect selected option (3.48 KB, patch)
2013-07-01 21:50 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 4907: 'Organize by' filter in suggestions doesn't reflect selected option (3.54 KB, patch)
2013-07-03 10:50 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 4907: 'Organize by' filter in suggestions doesn't reflect selected option (3.59 KB, patch)
2013-07-07 08:00 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2010-06-24 16:44:14 UTC
If I choose an option from the "organize by" menu to change the display of suggestions the resulting page doesn't automatically preselect that choice to reflect the current sort. If I choose Organize by -> Library then "Library" should be selected when the page redisplays.
Comment 1 Katrin Fischer 2011-10-29 12:58:27 UTC
But still existant in current master. Changing the 'organize by' option works, but the pull down always jumps back to 'Status'.
Comment 2 Katrin Fischer 2012-04-07 17:30:21 UTC
Bug still exists on current master.
Comment 3 Katrin Fischer 2013-07-01 21:24:08 UTC
*** Bug 9318 has been marked as a duplicate of this bug. ***
Comment 4 Katrin Fischer 2013-07-01 21:24:47 UTC
Another year... and the bug is still there.
Comment 5 Katrin Fischer 2013-07-01 21:50:35 UTC Comment hidden (obsolete)
Comment 6 Kyle M Hall 2013-07-03 10:50:21 UTC Comment hidden (obsolete)
Comment 7 Chris Cormack 2013-07-07 08:00:09 UTC
Created attachment 19450 [details] [review]
Bug 4907: 'Organize by' filter in suggestions doesn't reflect selected option

When using the 'Organize by' option to change the display of the
suggestions, the option is applied, but the pull down always jumps
back to the first entry 'Status'.

This patch fixes that.

To test:
- Try out all settings and verify that after the page reloads the selected
  option is applied to your suggestions and the pull down shows
  the option you selected.

Note: Until bug 10519 is properly fixed the tabs will not show
the correct descriptions, but the URL will show you the selected
option as parameter: displayby=acceptedby

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>
Comment 8 Galen Charlton 2013-07-08 15:17:00 UTC
Pushed to master.  Thanks, Katrin!
Comment 9 Tomás Cohen Arazi 2013-07-16 17:22:46 UTC
This patch has been pushed to 3.12.x, will be in 3.12.2.

Thanks Katrin!
Comment 10 Bernardo Gonzalez Kriegel 2013-08-04 13:43:51 UTC
Pushed to 3.10.x, will be in 3.10.10
Comment 11 Chris Hall 2013-09-16 08:42:53 UTC
Pushed to 3.8.x, will be in 3.8.18