Bug 5 - installer.pl doesn't set permissions correctly
Summary: installer.pl doesn't set permissions correctly
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: 1.2.x
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: Chris Cormack
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-06-25 03:34 UTC by Chris Cormack
Modified: 2012-10-24 21:03 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-20 23:24:59 UTC


---- Reported by tonnesen@cmsd.bc.ca 2002-06-25 03:34:22 ----

installer.pl sets ./intranet/cgi-bin, ./intranet/htdocs, ./intranet/modules,
./opac/cgi-bin, ./opac/htdocs, ./opac/modules readable only root, apache user
can't access the files



---- Additional Comments From tonnesen@cmsd.bc.ca 2002-06-25 04:12:46 ----

Added a system("chown -R root.$httpduser $opacdir") and same for $kohadir to
installer.pl.  There seems to be a lot of effort made to avoid using system()
calls in installer.pl, so I don't know if this solution will be popular.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-20 23:24 UTC  ---

This bug was previously known as _bug_ 5 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=5

Unknown operating system unknown. Setting to default OS "All".
Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was tonnesen@cmsd.bc.ca.