Bug 5048 - Error in bottom menu/submenu for select language in intranet
Summary: Error in bottom menu/submenu for select language in intranet
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: rel_3_0
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-21 09:07 UTC by Manuel González
Modified: 2012-10-25 23:03 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
language menu error at the bottom of the intranet (67.43 KB, image/jpeg)
2010-07-21 09:07 UTC, Manuel González
Details
Proposed fix for HEAD (3.98 KB, patch)
2010-07-21 18:41 UTC, Owen Leonard
Details | Diff | Splinter Review
Proposed fix for 3.0.x (4.02 KB, patch)
2010-07-21 19:30 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel González 2010-07-21 09:07:44 UTC
Created attachment 2400 [details]
language menu error at the bottom of the intranet

Hi. In KOHA intranet, at the bottom of the page there's a bar for select language. If there are more of one language with sublanguages, only appears correctly the first language menu, and the other menus are bad formed.
Comment 1 Owen Leonard 2010-07-21 15:33:56 UTC
I can confirm that this bugs affects 3.0.x (testing with the latest version in git) and that it doesn't affect HEAD. It looks like there is an error in the HTML structure.
Comment 2 Owen Leonard 2010-07-21 15:45:48 UTC
Correction: The problem didn't show up in HEAD because I didn't have the right combination of translations installed. It does indeed affect HEAD as well.
Comment 3 Owen Leonard 2010-07-21 18:41:11 UTC
Created attachment 2404 [details] [review]
Proposed fix for HEAD

This issue was apparently solved quite a while ago in the OPAC. This patch copies that solution over to the staff client.
Comment 4 Owen Leonard 2010-07-21 19:30:30 UTC
Created attachment 2405 [details] [review]
Proposed fix for 3.0.x
Comment 5 Chris Cormack 2010-12-01 20:25:33 UTC
Patch pushed to master
Comment 6 MJ Ray (software.coop) 2010-12-08 10:16:07 UTC
This bug is mentioned in:
Fix for Bug 5048,	Error in menu/submenu for select language in intranet http://lists.koha-community.org/pipermail/koha-patches/2010-November/012986.html