Bug 5051 - Renewal due date doesn't always show on patron Checkout tab
Summary: Renewal due date doesn't always show on patron Checkout tab
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-21 18:16 UTC by Jane Wagner
Modified: 2012-10-25 22:52 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Screen shot with missing renewal date box (29.38 KB, image/jpeg)
2010-07-21 18:16 UTC, Jane Wagner
Details
Screen shot where renewal date shows up after current day checkout (42.86 KB, image/jpeg)
2010-07-21 18:16 UTC, Jane Wagner
Details
Proposed fix (8.16 KB, patch)
2010-09-09 16:03 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jane Wagner 2010-07-21 18:16:06 UTC
Created attachment 2402 [details]
Screen shot with missing renewal date box

On the patron Details tab, in the list of checkouts, there is always a box for entering a due date for renewals with a calendar gadget.  This box does not always show on the patron Checkout tab.  The pattern seems to be that if nothing was checked out to the patron today, the renewal due date box doesn't show (first screenshot).  If you then check something out, the box shows (second screenshot), but it will be gone if you go back into the record tomorrow.

I don't think this is intended behavior but I'm not quite sure what's causing it.
Comment 1 Jane Wagner 2010-07-21 18:16:40 UTC
Created attachment 2403 [details]
Screen shot where renewal date shows up after current day checkout
Comment 2 Jane Wagner 2010-07-21 18:22:18 UTC
Note -- I tested this on an older system as well as current head -- same behavior.
Comment 3 Katrin Fischer 2010-09-09 15:13:36 UTC
I tested this today and the renewal date fields does not show up on the checkouts tab, only on the details tab.

An easy workaround is to always use the details tab, but it's still confusing and should work the same on both tabs.

Koha version: 	3.01.00.145
Comment 4 Owen Leonard 2010-09-09 16:03:15 UTC
Created attachment 2611 [details] [review]
Proposed fix

Display of the renewal date footer in the template was conditional upon
the existence of checkouts from today.

In order to fix this bug it was necessary to repeat the markup for the
table footer twice in the template, so I created an include file for it.
The same include file can now be used in moremember.tmpl.
Comment 5 Brice Sanchez 2010-10-04 15:56:47 UTC
(In reply to comment #4)
> Created attachment 2611 [details] [review]
> Proposed fix
> 
> Display of the renewal date footer in the template was conditional upon
> the existence of checkouts from today.
> 
> In order to fix this bug it was necessary to repeat the markup for the
> table footer twice in the template, so I created an include file for it.
> The same include file can now be used in moremember.tmpl.


What is the status of the patch? Will it be accepted?
Comment 6 Chris Cormack 2010-11-29 19:42:06 UTC
Patch pushed, please test
Comment 7 Jane Wagner 2010-11-30 15:41:13 UTC
Seems to be fixed in current head.  Thanks.