Bug 5068 - in add MARC record interface, concatenation of repeatable subfields in subject heading tags
Summary: in add MARC record interface, concatenation of repeatable subfields in subjec...
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: 3.4
Hardware: PC Linux
: P3 critical (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-28 15:29 UTC by Christopher Chagal
Modified: 2019-06-27 09:24 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Chagal 2010-07-28 15:29:38 UTC
pages involved:
cgi-bin/koha/authorities/auth_finder.pl
cgi-bin/koha/cataloguing/addbiblio.pl

In the add MARC record interface, repeated subfields from subject headings (imported from authorities) are being added to one subfield field, separated by a pipe, rather than being distributed to multiple subfields.  In addition, these subfields are being placed in an arbitrary order, rather than the order in which they appear in the authority record.

For instance, adding the subject "a$United States $xHistory $yCivil War, 1861-1865 $xCampaigns $vPictorial works" is instead entered into the new MARC record as "a$United States $vPictorial works $xHistory|Campaigns $yCivil War, 1861-1865."

Our catalogers also report that records imported from Z39.50 exhibit the same behavior if their subject fields contain repeated subfields.

We're running 3.00.05.001 (on Debian Lenny), but I was able to duplicate the bug on http://staff.kohademo.esilibrary.com, which is running 3.01.00.143 (HEAD?), so this bug is probably present in 3.2 as well.
Comment 1 Christopher Chagal 2010-08-05 14:03:02 UTC
Changing the affected Version to 3.2, since it also affects this branch.
Comment 2 Christopher Chagal 2011-06-07 20:17:59 UTC
This bug is still present in 3.4, in a slightly different way.

Instead of concatenating the |x fields, the MARC editor skips one of them. For example, when choosing the "United States|xHistory|yRevolution, 1775-1783|xPersonal narratives|vJuvenile literature" subject heading from our local authorities, the |xHistory subfield is left out when the data is distributed to the editor. Our catalogers tried adding another empty |x field before clicking the authority look up "..." link, but this just causes "xPersonal narratives" to fill every one after choosing this record.
Comment 3 Chris Nighswonger 2011-09-07 18:29:16 UTC
Is this still a problem in master or the latest 3.4.x release?
Comment 4 Jared Camins-Esakov 2011-12-23 16:58:29 UTC
I can confirm that this *is* still a bug, as Christopher Chagal described it in comment 2.
Comment 5 Katrin Fischer 2012-03-19 06:13:47 UTC
Jared - is this a bug in master too?
Comment 6 Jared Camins-Esakov 2012-03-19 13:08:08 UTC
This has been fixed in latest master.