Bug 5090 - New order from empty record does not save publication year and ISBN
Summary: New order from empty record does not save publication year and ISBN
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: rel_3_2
Hardware: All All
: PATCH-Sent (DO NOT USE) critical (vote)
Assignee: Katrin Fischer
QA Contact: Bugs List
URL:
Keywords:
: 4829 5178 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-08-04 18:09 UTC by Katrin Fischer
Modified: 2019-06-27 09:24 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
adding new record in acq (8.27 KB, image/png)
2010-08-04 18:09 UTC, Katrin Fischer
Details
edit order (7.45 KB, image/png)
2010-08-04 18:20 UTC, Katrin Fischer
Details
Proposed patch (5.26 KB, patch)
2010-08-08 15:26 UTC, Katrin Fischer
Details | Diff | Splinter Review
screenshot (5.38 KB, image/png)
2010-10-06 22:07 UTC, Katrin Fischer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2010-08-04 18:09:47 UTC
Created attachment 2461 [details]
adding new record in acq

New order from empty record does not save publication year and ISBN. The entered values are not displayed when editing the order or in cataloging.

I added a mapping from 260c to biblioitems.publicationyear. After that, publication year was saved in the record and displayed in cataloging, but the value was still not shown when editing the order in acquisitions.

ISBN is mapped to 20$a by default, but it is not saved in the record.


Tested with: 
MARC21
Koha version: 	3.01.00.145
AcqCreateItem   Create an item when placing an order.
Comment 1 Katrin Fischer 2010-08-04 18:20:45 UTC
Created attachment 2462 [details]
edit order

In my first tests I entered "year" as publication year. This value is saved to the marc record after mapping biblioitems.publicationyear to 260c but is not shown in acquitisions.

But real years like "2010" work. They are shown correctly in acq.

I was not able to get the ISBN to show or be saved to the MARC record.
Comment 2 dev_patches 2010-08-05 13:29:13 UTC
It seems you are missing an ACQ framework.
Comment 3 Katrin Fischer 2010-08-05 13:36:23 UTC
I'm not sure this is the problem. 

What I found out is, that MARC21 has no default mapping to biblioitems.publicationyear. addorder.pl checks the field mapped to biblioitems.publicationyear to create a MARC record. Because it is not mapped, the publication year is not saved.

260$c is mapped to biblio.copyrightdate in MARC21. 
biblioitems.publicationyear is only mapped for UNIMARC.

I worked on the bug yesterday to solve the problem. What helps is to map biblioitems.publicationyear to a field, but I think it should work with standard fields and mappings.
Comment 4 Katrin Fischer 2010-08-08 15:26:53 UTC
Created attachment 2482 [details] [review]
Proposed patch

- make publication year save for MARC21 
- make ISBN save
- fix small template issue with label for vendor note
Comment 5 Owen Leonard 2010-08-26 16:02:37 UTC
*** Bug 5178 has been marked as a duplicate of this bug. ***
Comment 6 Nicole C. Engard 2010-08-26 16:09:14 UTC
*** Bug 4829 has been marked as a duplicate of this bug. ***
Comment 7 Katrin Fischer 2010-10-06 22:06:30 UTC
Tested successfully on current head, closing bug.
Comment 8 Katrin Fischer 2010-10-06 22:07:13 UTC
Created attachment 2676 [details]
screenshot

All information is saved now.