Bug 5111 - no way to delete a vendor
Summary: no way to delete a vendor
Status: CLOSED INVALID
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Henri-Damien LAURENT
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-10 12:28 UTC by Nicole C. Engard
Modified: 2017-12-07 22:17 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2010-08-10 12:28:57 UTC
There should be a way to delete a vendor from your system. Sometimes staff members will enter the same vendor more than once without checking and there should be a mechanism to delete these duplicates (or any vendor for that matter).
Comment 1 Owen Leonard 2010-08-10 12:33:00 UTC
This came up in an IRC discussion at one point, and it was pointed out that you shouldn't be able to delete a vendor from which orders have been placed because that would mess up information in other places. If a vendor delete option is added it should have a method of checking to see if the vendor ID is in use anywhere else.
Comment 2 Katrin Fischer 2010-08-10 12:34:41 UTC

*** This bug has been marked as a duplicate of bug 4969 ***
Comment 3 Jonathan Druart 2017-03-07 18:59:23 UTC
Marked as invalid instead of duplicate.