Bug 5140 - In Chrome, drop-down menus disappear after using pop-up calendar
Summary: In Chrome, drop-down menus disappear after using pop-up calendar
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Browser compatibility (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-16 17:18 UTC by Owen Leonard
Modified: 2012-10-25 23:04 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Screenshot showing the problem (20.80 KB, image/png)
2010-08-16 17:21 UTC, Owen Leonard
Details
Proposed fix (4.31 KB, patch)
2010-08-16 19:12 UTC, Owen Leonard
Details | Diff | Splinter Review
calendar in chrome on mac (32.37 KB, image/png)
2011-02-16 21:10 UTC, Nicole C. Engard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2010-08-16 17:18:35 UTC
To reproduce, try the Acquisitions statistics report in Google Chrome. When you click a calendar icon to show the date picker, <select> form fields disappear. In other browsers the fields reappear after the date picker is closed, but in Chrome they remain hidden.

The disappearing behavior is designed to get around a display bug in Internet Explorer 6 in which <select> fields "bleed through" HTML elements which are displayed on top of them. The JavaScript calendar library we use has a built in routine to hide any <select> elements which are positioned after the calendar pop-up. For some reason the JavaScript code fails to redisplay the <select> fields in Chrome.

The "bleed through" bug has been fixed in IE7+, so I'm inclined to remove the hiding behavior altogether and let IE6 users live with it (as they do so many other horrible CSS bugs anyway).
Comment 1 Owen Leonard 2010-08-16 17:21:39 UTC
Created attachment 2525 [details]
Screenshot showing the problem

Drop-down menus for patron category, item type, etc. have disappeared.
Comment 2 Owen Leonard 2010-08-16 19:12:23 UTC
Created attachment 2526 [details] [review]
Proposed fix

Disabling that part of the calendar JavaScript which hides <select> form fields when the calendar is displayed. This is at the expense of IE6.
Comment 3 Owen Leonard 2010-08-16 19:14:30 UTC
The bug and the patch also apply to rel_3_0.
Comment 4 Nicole C. Engard 2011-02-16 21:10:40 UTC
Created attachment 3166 [details]
calendar in chrome on mac

I tested the patch and it doesn't fix anything ... also my calendar doesn't show the month (as attached).
Comment 6 Nicole C. Engard 2011-02-16 21:16:11 UTC
Tested right this time and it works :) Signed off.

My calendar still has a black bar where the month should be though.
Comment 7 Owen Leonard 2011-02-17 18:05:21 UTC
> My calendar still has a black bar where the month should be though.

This seems to be a bug specific to Chrome on the Mac, and can be explained by the calendar widget's use of now-deprecated "System Colors" in its CSS. The best workaround in the short term is to add a custom CSS declaration to your IntranetUserCSS preference:  

div.calendar thead td.title { background: #DDD none; }
Comment 8 Chris Cormack 2011-02-17 21:48:24 UTC
Pushed to master
Comment 9 MJ Ray (software.coop) 2011-03-06 12:10:00 UTC
This bug is mentioned in:
Fix for Bug 5140 - In Chrome,	drop-down menus disappear after using pop-up calendar http://lists.koha-community.org/pipermail/koha-patches/2011-February/013880.html