Bug 5143 - Subtitles not showing on view_holdsqueue.pl
Summary: Subtitles not showing on view_holdsqueue.pl
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) trivial (vote)
Assignee: Liz Rea
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-17 16:02 UTC by Liz Rea
Modified: 2012-10-25 23:04 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Potential fix (3.65 KB, patch)
2010-08-17 21:57 UTC, Chris Cormack
Details | Diff | Splinter Review
followup-putting the subtitles in the URL for title (1.68 KB, patch)
2010-08-18 19:59 UTC, Liz Rea
Details | Diff | Splinter Review
followup putting the subtitles in the title links (3.86 KB, patch)
2010-08-18 21:32 UTC, Liz Rea
Details | Diff | Splinter Review
Final squashed patch for this issue. (8.93 KB, patch)
2010-12-14 17:18 UTC, Liz Rea
Details | Diff | Splinter Review
Revised fix (7.13 KB, patch)
2010-12-14 19:10 UTC, Owen Leonard
Details | Diff | Splinter Review
Revised revised fix (7.26 KB, patch)
2010-12-14 19:21 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2010-08-17 16:02:06 UTC
see: http://screencast.com/t/OWE5NzMxZWMt

Subtitles are not showing on the Holds Queue list, making it very time consuming for librarians to pick items that are in a series.

The holds queue used to show the barcode of the item to be picked, making it eas(ier) for the librarian to find the right item to fill a hold. Without the subtitles AND without the barcode, they have to click through to each subtitled item to figure out which item to pull. 

I propose adding the subtitles into the holds queue list, and considering adding the specific item barcode back in as well (though there may be a reason not to do that).
Comment 1 Chris Cormack 2010-08-17 21:20:05 UTC
The specific barcode is there, if a specific item was requested.

Any available title does let the person know, any copy on the shelf will suffice. 
But adding in the subtitle, $b and $p and $n at least for libraries using MARC21 is certainly doable.
Comment 2 Chris Cormack 2010-08-17 21:27:13 UTC
Using the Keyword to MARC mappings
/cgi-bin/koha/admin/fieldmapping.pl

We can define mappings for those subfields, then we can use those mappings to make a multi marc compliant solution.

Using GetRecordValue from C4::Biblio
Comment 3 Chris Cormack 2010-08-17 21:57:38 UTC Comment hidden (obsolete)
Comment 4 Owen Leonard 2010-08-18 00:00:16 UTC
> Any available title does let the person know, any copy on the shelf will
> suffice. 

The trouble with this is when your library has more than one copy of the same title, but because they have different ISBNs they were cataloged under separate records. Pulling one of the two [different] copies of that title has only a 50% chance of fulfilling the hold in your report.

We use a custom PHP script which pulls from Koha's holdsqueue table and does a "limit 1" query for barcode for each item in the holds list. It has worked well for us. I don't know whether a similar method would work well as a built-in report.
Comment 5 Jane Wagner 2010-08-18 11:23:23 UTC
I see there was a followup patch; is the version attached to this bug report the correct one?
Comment 6 Owen Leonard 2010-08-18 12:24:26 UTC
I'm assuming the modifications to addbiblio.tmpl in this patch are unrelated?
Comment 7 Liz Rea 2010-08-18 14:34:46 UTC
I can confirm that with chris's patch, subtitles are now showing in the View Holdsqueue.

There is still the matter of the barcodes that owen brings up, but this patch definitely helps the bigger issue with our libraries, which is picking items with entries in the 245 $p, $n, $b, and $h.

http://screencast.com/t/ZGZjMTdjND
Comment 8 Liz Rea 2010-08-18 14:45:39 UTC
For purposes of comparison: this is the holds queue list that we are currently using. It was customized by me to only show what we wanted.

http://screencast.com/t/ZmE5NDcyY

Additionally, putting patron information on the holds queue, while helpful, requires librarians to shred the list when they are done. We omitted it for that reason, as the information is printed on the slip when the item is checked in.
Comment 9 Liz Rea 2010-08-18 19:59:56 UTC Comment hidden (obsolete)
Comment 10 Liz Rea 2010-08-18 21:32:32 UTC Comment hidden (obsolete)
Comment 11 Owen Leonard 2010-12-13 17:26:33 UTC
Looks like the fix requires both attachment 2533 [details] [review] and attachment 2552 [details] [review]. After testing with both of those I can confirm the holds queue list shows subtitles. However, attachment 2533 [details] [review] includes some changes to addbiblio.tmpl which don't belong. Liz, can you send a single revised patch?
Comment 12 Chris Cormack 2010-12-14 00:23:46 UTC
New patch has been sent, awaiting sign off
Comment 13 Liz Rea 2010-12-14 17:18:34 UTC Comment hidden (obsolete)
Comment 14 Nicole C. Engard 2010-12-14 19:02:49 UTC
I tried to test and sign off - but got a failed message.  This could be my fault, so I'm sharing here in case I did something wrong.
nengard@debian:~/kohaclone$ git am -3 -i -u bug5143.patch
Commit Body is:
--------------------------
Potential fix for 5143, now with IE debug removed Need to set up keyword to marc mappings for subtitle, parts, numbers for this to work

Squashed commit of the following:

commit 555e8a872408371ca9e730b41a61d4fdbb897d51
Author: Chris Cormack <chrisc@catalyst.net.nz>
Date:   Wed Aug 18 21:52:32 2010 +1200

   Removing IE debug

commit 11df1c363af3fe660e25fb1b18885d205137adb4
Author: Chris Cormack <chrisc@catalyst.net.nz>
Date:   Wed Aug 18 09:52:31 2010 +1200

   Final fix for this bug 5143

commit efbb69d898c07332404d6ca906f801ad7ae89707
Author: Chris Cormack <chrisc@catalyst.net.nz>
Date:   Wed Aug 18 09:40:09 2010 +1200

   Typo fix

commit 0b9423ab3910138e561d73e63190a2a51c7bb603
Author: Chris Cormack <chrisc@catalyst.net.nz>
Date:   Wed Aug 18 09:36:47 2010 +1200

   Bug 5143, adding subtile, parts and numbers to the holdsqueue report

[Bug 5143] Subtitles not showing on view-holdsqueue.pl

Seeking sign off.

adds:
- the subtitles into the title link (originally Chris Cormack)
- barcodes for every listed hold
- denoted which items were only item and which could be filled by any item on that bib.
- added id's to every column for ease of jquery suppression of data (example: publication data or patron column could be suppressed)

[bug 5143] Fixing whitespace errors.

More whitespace corrections
--------------------------
Apply? [y]es/[n]o/[e]dit/[v]iew patch/[a]ccept all y
Applying Potential fix for 5143, now with IE debug removed Need to set up keyword to marc mappings for subtitle, parts, numbers for this to work
fatal: corrupt patch at line 11
Patch failed at 0001.
When you have resolved this problem run "git-am -i -3 --resolved".
If you would prefer to skip this patch, instead run "git-am -i -3 --skip".
nengard@debian:~/kohaclone$
Comment 15 Owen Leonard 2010-12-14 19:10:47 UTC Comment hidden (obsolete)
Comment 16 Owen Leonard 2010-12-14 19:21:44 UTC
Created attachment 2847 [details] [review]
Revised revised fix
Comment 17 Chris Cormack 2010-12-14 20:34:19 UTC
Pushed to master, please test
Comment 18 Liz Rea 2010-12-16 16:43:27 UTC
Works!

(In reply to comment #17)
> Pushed to master, please test
Comment 19 Chris Cormack 2010-12-16 20:03:43 UTC
New patch was sent with help files, needs signoff
Comment 20 Nicole C. Engard 2010-12-17 23:20:25 UTC
signed off on help file changes
Comment 21 Chris Cormack 2010-12-20 13:55:01 UTC
New help files pushed, please test
Comment 22 MJ Ray (software.coop) 2011-01-05 23:21:40 UTC
This bug is mentioned in:
[Bug 5143] Adding help text to point users	to add keyword to MARC mappings for subtitle fields. http://lists.koha-community.org/pipermail/koha-patches/2010-December/013388.html
Bug 5143: Help file revisions	per Owen Leonard http://lists.koha-community.org/pipermail/koha-patches/2010-December/013424.html
[Bug 5143] Help file revisions per Owen	Leonard http://lists.koha-community.org/pipermail/koha-patches/2010-December/013414.html