Bug 5146 - Patron Import Requires Header Row
Summary: Patron Import Requires Header Row
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Target Milestone: ---
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-18 12:06 UTC by Nicole C. Engard
Modified: 2010-11-30 15:54 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
patron import summary (49.29 KB, image/png)
2010-08-18 12:06 UTC, Nicole C. Engard
Details
proposed patch (2.36 KB, patch)
2010-10-28 12:02 UTC, Galen Charlton
Details | Diff | Splinter Review
screenshot of import status (2) (42.83 KB, image/png)
2010-10-30 21:25 UTC, Nicole C. Engard
Details
csv i tried to import (120 bytes, application/vnd.ms-excel)
2010-10-30 21:25 UTC, Nicole C. Engard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2010-08-18 12:06:24 UTC
Created attachment 2538 [details]
patron import summary

On the patron import page it says: "You may optionally include a header row, defining which columns you are supplying in the import file." but the header row is actually required or else Koha will ignore the first row you're importing.  

I tried two tests, one with a header row and only the fields with data in them and both records imported just fine.  The second test was with all of the possible fields and no header row - this one listed my first patron as the header row and only imported those after him. (see attached)
Comment 1 Galen Charlton 2010-10-28 12:00:14 UTC
Submitted patch.
Comment 2 Galen Charlton 2010-10-28 12:02:42 UTC
Created attachment 2706 [details] [review]
proposed patch
Comment 3 Galen Charlton 2010-10-30 12:15:59 UTC
Fix now in master.  Please test.
Comment 4 Nicole C. Engard 2010-10-30 21:25:05 UTC
Created attachment 2722 [details]
screenshot of import status (2)

I do not believe this is working.  I have upgraded to HEAD and just imported a CSV without a header row and it failed.  See attached.
Comment 5 Nicole C. Engard 2010-10-30 21:25:32 UTC
Created attachment 2723 [details]
csv i tried to import
Comment 6 Galen Charlton 2010-10-30 21:39:03 UTC
The header row is required.  That did not change and is not likely to.  The fix was to the help text on the page that mistakenly said that the header row was optional.
Comment 7 Nicole C. Engard 2010-10-30 21:42:46 UTC
oh! :) okay then this works.
Comment 8 Chris Nighswonger 2010-11-18 03:15:42 UTC
This bug has a patch presently committed to HEAD and 3.2.x.

Please take the appropriate action to update the status of this bug.

Remember, bugs which have been resolved should be tested and marked closed, preferably by the original reporter.
Comment 9 Chris Nighswonger 2010-11-30 15:54:54 UTC
A fix for this bug has been committed to the current development HEAD as well as released in 3.2.1.