Bug 5180 - Autocomplete broken on overdues report
Summary: Autocomplete broken on overdues report
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: 3.6
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Bugs List
URL: /cgi-bin/koha/circ/overdue.pl
Keywords:
Depends on:
Blocks: 5014
  Show dependency treegraph
 
Reported: 2010-08-27 13:03 UTC by Owen Leonard
Modified: 2013-12-05 19:53 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 5180: FIX autocomplete on overdues report (2.80 KB, patch)
2012-03-14 13:39 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 5180: FIX autocomplete on overdues report (2.90 KB, patch)
2012-03-22 07:00 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2010-08-27 13:03:37 UTC
There is a JavaScript error on the overdues report page. FireBug reports:

YAHOO.widget.DS_XHR is not a constructor
/cgi-bin/koha/circ/overdue.pl
Line 126

This bug blocks Bug 5014 because without a working autocomplete I don't know if the markup corrections I think are required to fix 5014 will break the autocomplete.
Comment 1 Jonathan Druart 2012-03-14 13:39:15 UTC Comment hidden (obsolete)
Comment 2 Jared Camins-Esakov 2012-03-17 01:08:42 UTC
Is this still an issue? I can't seem to replicate it based on the description on the patch.
Comment 3 Paul Poulain 2012-03-22 05:06:11 UTC
(In reply to comment #2)
> Is this still an issue? I can't seem to replicate it based on the
> description on the patch.

I can't reproduce it either. Owen, still relevant ?
Comment 4 Owen Leonard 2012-03-22 07:00:26 UTC
Created attachment 8464 [details] [review]
[SIGNED-OFF] Bug 5180: FIX autocomplete on overdues report

- Switch off the CircAutocompl syspref
- Set a (one or more) patron attr type searchable
- go on the overdues page
Firebug crash and a layout problem appears on the left.

Firebug error is "YAHOO.widget.DS_XHR is not a constructor"

retry with this patch.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 5 Owen Leonard 2012-03-22 07:03:56 UTC
Yes, this is still an issue in master, and the test plan is the same as what I'm seeing. This patch disables the autocomplete when CircAutocompl is turned off, which may not be what everyone would expect. Perhaps CircAutocompl should be officially transformed into a global switch for autocomplete? jQueryUI will certainly make it easier to add more instances of it.
Comment 6 Paul Poulain 2012-03-22 09:51:13 UTC
QA comment : I can't reproduce the issue. However, it's a tiny patch, the code is correct and sound logical. There should be something specific in the configuration I can't reproduce.
However, Jonathan and owen confirm the problem exist and the patch fixes it, I have no problem after applying the patch, so passed QA


BREAKING NEWS: just 2sec before hitting "save", jonathan suggested something, now I can reproduce the problem = the attribute must be searchable and linked to an authorised value
Comment 7 Jared Camins-Esakov 2012-05-09 16:55:35 UTC
This bug will be included in the Koha 3.6.5 release.