Bug 5182 - Attempting to export a patron card with no text causes an error to be thrown
Summary: Attempting to export a patron card with no text causes an error to be thrown
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Label/patron card printing (show other bugs)
Version: rel_3_2
Hardware: All All
: PATCH-Sent (DO NOT USE) critical (vote)
Assignee: Chris Nighswonger
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-27 18:28 UTC by Chris Nighswonger
Modified: 2019-06-27 09:24 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Nighswonger 2010-08-27 18:28:42 UTC
Specifically:

Can't use an undefined value as an ARRAY reference at /home/koha/koha.prod/C4/Patroncards/Patroncard.pm line 86.

This is caused by testing for text at line 87 rather than line 85. A patch is forth coming to fix this.
Comment 1 Chris Nighswonger 2010-09-09 19:56:32 UTC
Pull request submitted.

Patch is available here:

http://git.koha-community.org/gitweb/?p=wip/koha-fbc.git;a=commit;h=a51ca36ea9130fe8ba52e8e2c42a25bf75d21106