Bug 5203 - Creating a label template causes fatal error if description field is empty
Summary: Creating a label template causes fatal error if description field is empty
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Label/patron card printing (show other bugs)
Version: rel_3_2
Hardware: All All
: PATCH-Sent (DO NOT USE) minor (vote)
Assignee: Chris Nighswonger
QA Contact: Bugs List
URL:
Keywords:
: 5238 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-09-07 20:27 UTC by Liz Rea
Modified: 2012-10-25 23:03 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Liz Rea 2010-09-07 20:27:32 UTC
Attempting to save a label template causes a fatal error 

Software error:

Can't call method "save" without a package or object reference at /home/liz/kohaclone/labels/label-edit-template.pl line 102.
For help, please send mail to the webmaster (webmaster@koha-deb), giving this error message and the time and date of the error.

when the default text is removed and no text is typed into the description field (it's empty).
Comment 1 Chris Nighswonger 2010-09-23 17:52:14 UTC
*** Bug 5238 has been marked as a duplicate of this bug. ***
Comment 2 Chris Nighswonger 2010-09-23 17:57:16 UTC
This is due to the underlying script not having any defaults hard coded which results in skewed hash elements when the parameter array is coerced into a hash at a later point.

This also occurs in layouts and profiles. This patch adds defaults to all three.

No documentation changes are necessary.

The patch is available here:

http://git.koha-community.org/gitweb/?p=wip/koha-fbc.git;a=shortlog;h=refs/heads/k_bug_5203

Please test, sign-off, and submit to patches@...
Comment 3 Chris Nighswonger 2010-09-23 17:57:51 UTC
Updating time.
Comment 4 Nicole C. Engard 2010-12-16 16:57:42 UTC
has this patch been pushed? When I try  (Before applying the patch) I can't clear out the description at all.  I get no error, but if I save with an empty description it puts the 'default description' in again.