Bug 5229 - OPACItemsResultsDisplay preference must be removed
Summary: OPACItemsResultsDisplay preference must be removed
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Marcel de Rooy
URL:
Keywords:
: 2619 (view as bug list)
Depends on: 12561
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-16 14:48 UTC by Owen Leonard
Modified: 2021-11-22 10:14 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
21.11.00


Attachments
Bug 5229: Remove system preference 'OPACItemsResultsDisplay' (11.52 KB, patch)
2021-11-15 11:49 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 5229: Remove system preference 'OPACItemsResultsDisplay' (11.00 KB, patch)
2021-11-15 14:09 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 5229: Remove system preference 'OPACItemsResultsDisplay' (11.05 KB, patch)
2021-11-16 12:16 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 5229: Remove from searching.pref (1.24 KB, patch)
2021-11-16 12:16 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 5229: Remove system preference 'OPACItemsResultsDisplay' (11.15 KB, patch)
2021-11-19 07:15 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 5229: Remove from searching.pref (1.34 KB, patch)
2021-11-19 07:15 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 5229: (QA follow-up) Remove last occurrence in code (1.29 KB, patch)
2021-11-19 07:15 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2010-09-16 14:48:48 UTC
The description for the preference says "show/don't show an item's branch, location and call number in OPAC search results." The preference works with normal results, the alternatives being:

Availability:  Copies available:  Athens (1) ("don't show")

and

Availability:  Copies available:  Athens [AF Needle] (1) ("show")

In the OPAC's XSLT results display the latter version appears no matter what the preference is set to.
Comment 1 Katrin Fischer 2019-05-04 18:13:02 UTC
*** Bug 2619 has been marked as a duplicate of this bug. ***
Comment 2 Lucas Gass 2021-06-10 14:08:55 UTC
This appears to still be valid.
Comment 3 Nick Clemens 2021-06-15 11:06:29 UTC
The preference description is inaccurate:
"show/don't show an item's branch, location and call number in OPAC search results."

It does not affect display of branch, only location and callnumber.

OPACItemLocation has an option for 'only branch' which seems to be equivalent functionality.

Can we just link the preferences to display together and indicate one is XSLT and one is not?
Comment 4 Katrin Fischer 2021-06-15 12:18:40 UTC
I think a goal is to remove the non-XSLT display this release - so I think better to work towards that.
Comment 5 Nick Clemens 2021-06-15 13:32:28 UTC
(In reply to Katrin Fischer from comment #4)
> I think a goal is to remove the non-XSLT display this release - so I think
> better to work towards that.

So then we simply remove this preference?
Comment 6 Katrin Fischer 2021-06-15 22:05:36 UTC
If we can confirm that there is equal functionality for the XSLT view - I think that would be consequential.
Comment 7 Jonathan Druart 2021-10-18 13:05:08 UTC
Hum... We removed the feature but forgot the syspref.

  commit 56c2856e268ec02638898923d751a0b69c716f93
  Bug 12561: Remove non-XSLT views
Comment 8 Jonathan Druart 2021-11-15 11:46:41 UTC
Renaming bug report, we should now just remove the pref.
Comment 9 Jonathan Druart 2021-11-15 11:49:28 UTC
Created attachment 127631 [details] [review]
Bug 5229: Remove system preference 'OPACItemsResultsDisplay'

We dropped it on bug 12561 when removing the non-XSLT view. This feature
has never been implemented for XSLT views and the pref must then be
removed.
Comment 10 Jonathan Druart 2021-11-15 14:09:15 UTC
Created attachment 127655 [details] [review]
Bug 5229: Remove system preference 'OPACItemsResultsDisplay'

We dropped it on bug 12561 when removing the non-XSLT view. This feature
has never been implemented for XSLT views and the pref must then be
removed.
Comment 11 Tomás Cohen Arazi 2021-11-16 12:16:05 UTC
Created attachment 127689 [details] [review]
Bug 5229: Remove system preference 'OPACItemsResultsDisplay'

We dropped it on bug 12561 when removing the non-XSLT view. This feature
has never been implemented for XSLT views and the pref must then be
removed.

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 12 Tomás Cohen Arazi 2021-11-16 12:16:10 UTC
Created attachment 127690 [details] [review]
Bug 5229: Remove from searching.pref

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 13 Marcel de Rooy 2021-11-19 07:12:34 UTC
QAing
Comment 14 Marcel de Rooy 2021-11-19 07:15:26 UTC
Created attachment 127821 [details] [review]
Bug 5229: Remove system preference 'OPACItemsResultsDisplay'

We dropped it on bug 12561 when removing the non-XSLT view. This feature
has never been implemented for XSLT views and the pref must then be
removed.

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 15 Marcel de Rooy 2021-11-19 07:15:30 UTC
Created attachment 127822 [details] [review]
Bug 5229: Remove from searching.pref

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 16 Marcel de Rooy 2021-11-19 07:15:34 UTC
Created attachment 127823 [details] [review]
Bug 5229: (QA follow-up) Remove last occurrence in code

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 17 Jonathan Druart 2021-11-19 14:11:01 UTC
(In reply to Marcel de Rooy from comment #16)
> Created attachment 127823 [details] [review] [review]
> Bug 5229: (QA follow-up) Remove last occurrence in code
> 
> Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>

I let it there on purpose. At the time it made sense to keep it, today I don't know why we should keep it :D

I will skip the patch as it will (easy) conflict with bug 29494 that is removing completely the file.
Comment 18 Jonathan Druart 2021-11-19 14:15:32 UTC
Pushed to master for 21.11, thanks to everybody involved!