Bug 5513 - staff client display all screwy if you don't have all permissions
Summary: staff client display all screwy if you don't have all permissions
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff Client (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL: /cgi-bin/koha/mainpage.pl
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-16 15:54 UTC by Nicole C. Engard
Modified: 2012-10-25 22:53 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
staff client to a circ librarian (67.49 KB, image/png)
2010-12-16 15:54 UTC, Nicole C. Engard
Details
Proposed fix (1.22 KB, patch)
2010-12-17 14:48 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2010-12-16 15:54:39 UTC
Created attachment 2866 [details]
staff client to a circ librarian

When logged in as a circulation librarian with 'catalogue', 'circulate_remaining_permissions', and 'borrow' permissions the screen display gets all kinds of messed up in FF on Mac.
Comment 1 Owen Leonard 2010-12-17 14:48:44 UTC
Created attachment 2873 [details] [review]
Proposed fix

The cause of this bug was the removal of a closing <!-- /TMPL_IF --> in a recent commit.
Comment 2 Nicole C. Engard 2010-12-17 16:10:47 UTC
much better
Comment 3 Nicole C. Engard 2010-12-17 16:14:11 UTC
Oops - nevermind that sign off - this happens on other pages still:

cgi-bin/koha/catalogue/search.pl?q=book

And probably more, but I can't get back home once that happens.
Comment 4 Nicole C. Engard 2010-12-17 16:23:36 UTC
silly me, multi-tasking error on my part - this works a-ok
Comment 5 Chris Cormack 2010-12-18 18:47:46 UTC
Pushed, please test