Bug 5546 - Ability to hide MARC documentation links
Summary: Ability to hide MARC documentation links
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: 3.4
Hardware: All All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Assignee: Tomás Cohen Arazi
QA Contact: Bugs List
URL:
Keywords:
Depends on: 6257
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-28 13:39 UTC by Tomás Cohen Arazi
Modified: 2012-10-25 23:04 UTC (History)
4 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Add sysprefs and use then to hide MARC docs stuff (5.95 KB, patch)
2010-12-28 14:50 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Javascript-driven version - cookies missing yet (7.74 KB, patch)
2010-12-30 14:06 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Initial patch / cookies enabled (6.88 KB, patch)
2011-03-01 14:14 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Cleanup, simplify, by Owen Leonard (2.96 KB, patch)
2011-03-09 18:37 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Purge initial file (4.95 KB, patch)
2011-04-04 13:03 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Tomás Cohen Arazi 2010-12-28 13:39:54 UTC
We should add a syspref to control the visibility of the MARC documentation links on the cataloguing interface.
Comment 1 Tomás Cohen Arazi 2010-12-28 14:50:12 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2010-12-28 15:01:32 UTC
We could also include a checkbox somewhere onscreen which controlled via JavaScript whether the documentation links appeared:

[ ] Show MARC tag documentation links

Then the option could be there for users who wanted it. The choice could be saved in a cookie.
Comment 3 Tomás Cohen Arazi 2010-12-28 15:39:50 UTC
Hoho, spanish-speaking mixes things up. hahaha
Comment 4 Tomás Cohen Arazi 2010-12-30 14:06:52 UTC Comment hidden (obsolete)
Comment 5 MJ Ray (software.coop) 2011-01-11 12:57:47 UTC
This bug is mentioned in:
[Bug 5546] syspref to hide MARC	documentation links http://lists.koha-community.org/pipermail/koha-patches/2010-December/013463.html
[Bug 5546] javascript version - cookies	handling missing yet http://lists.koha-community.org/pipermail/koha-patches/2010-December/013469.html
[Bug 5546] javascript version - cookies	handling missing yet http://lists.koha-community.org/pipermail/koha-patches/2010-December/013470.html
[Bug 5546] javascript version - cookies	handling missing yet http://lists.koha-community.org/pipermail/koha-patches/2010-December/013471.html
Comment 6 Tomás Cohen Arazi 2011-03-01 14:14:18 UTC Comment hidden (obsolete)
Comment 7 Tomás Cohen Arazi 2011-03-09 18:37:18 UTC
Created attachment 3275 [details] [review]
Cleanup, simplify, by Owen Leonard
Comment 8 Jonathan Druart 2011-04-04 13:03:38 UTC
Created attachment 3623 [details] [review]
Purge initial file

Original patch does not apply. Caused by existing modification.
Comment 9 Frederic Durand 2011-04-04 13:46:53 UTC
Checkbox on biblio notice appears correctly, well saved in cookie, refreshing the web page keep choice we did.
Comment 10 Tomás Cohen Arazi 2011-04-04 17:43:10 UTC
It is worth checking cookies work on a per-borrowernumber basis. It works here.
Comment 11 Chris Cormack 2011-04-05 03:12:58 UTC
Signed off patch not on mailing list or attached
Comment 12 MJ Ray (software.coop) 2011-04-09 09:25:34 UTC
This bug is mentioned in:
[Bug 5546] Javascript driven ability to hide	MARC documentation links http://lists.koha-community.org/pipermail/koha-patches/2011-March/013954.html
[Bug 5546] Follow-up / fixes http://lists.koha-community.org/pipermail/koha-patches/2011-March/014016.html
Comment 13 Chris Cormack 2011-04-10 07:28:33 UTC
Pushed please test
Comment 14 Matthias Meusburger 2011-07-08 10:13:59 UTC
Works for me.