Bug 5568 - Upgrade Amazon module to support Product Advertising API
Summary: Upgrade Amazon module to support Product Advertising API
Status: CLOSED WONTFIX
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low normal (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL:
Keywords:
: 5747 (view as bug list)
Depends on:
Blocks: 2712 3389
  Show dependency treegraph
 
Reported: 2011-01-02 06:44 UTC by Jeremy Bicha
Modified: 2012-10-26 00:51 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Bicha 2011-01-02 06:44:38 UTC
Amazon reviews no longer display in OPAC because Amazon has changed the API again. More information can be found in the documentation: http://aws.amazon.com/archives/Product%20Advertising%20API

===
Dear Developer,

On November 8, 2010 the Reviews response group of the Product Advertising API will no longer return customer reviews content and instead will return a link to customer reviews content hosted on Amazon.com. You will be able to display customer reviews on your site using that link. Please refer to the Product Advertising API Developer guide found here for more details. The Reviews response group will continue to function as before until November 8 and the new link to customer reviews is available to you now through the Product Advertising API as well.

We are introducing efficiency guidelines for high volume users related to API usage. These guidelines are designed to promote efficient use of the API while providing the most effective advertising functionality and feature-set for application developers like you. Starting October 15 all usage will be subject to the efficiency guidelines. In addition, due to low usage, we plan to deprecate a subset of API operations and response groups. Please refer to the "Efficiency Guidelines" and "API Changes" sections below for details on the efficiency guidelines and API operations/response groups slated for deprecation. The efficiency guidelines will be phased in over a period of three months, starting July 15, and by October 15 all usage will be subject to these guidelines.

The Product Advertising API Team.

Efficiency Guidelines
The purpose of the Product Advertising API is to advertise Amazon Products and thereby enable Associates to make money by creating Amazon advertisements and sending traffic back to Amazon. A small number of users are requesting very large amounts of product data while generating a very small amount of product sales. The Product Advertising API efficiency guidelines are designed to promote efficient use of the API. Each account used to access the Product Advertising API will be allowed an initial usage limit of 2,000 requests per hour. Each account will receive an additional 500 requests per hour (up to a maximum of 25,000 requests per hour) for every $1 of shipped item revenue driven per hour in a trailing 30-day period. Usage thresholds are recalculated daily based on revenue performance. To ensure that each account qualifies for the additional threshold increase, the URLs served by the Product Advertising API must be used when linking back to Amazon and the Associate tags used must belong to the account owner.

API Changes
Due to low usage, the Product Advertising API operations and response groups listed below will not be supported after October 15, 2010:

    Operations: CustomerContentLookup, CustomerContentSearch, Help, ListLookup, ListSearch, TagLookup, TransactionLookup, VehiclePartLookup, VehiclePartSearch, VehicleSearch.
    Response Group: ListmaniaLists, MerchantItemAttributes, PromotionDetails, Subjects, Tags, TagsSummary, VariationMinimum

Additionally, due to low usage, we will be discontinuing Multiple Operation Requests and the TextStream search parameter. 

===
Comment 1 Owen Leonard 2011-02-11 20:17:54 UTC
*** Bug 5747 has been marked as a duplicate of this bug. ***
Comment 2 Owen Leonard 2012-02-17 15:13:15 UTC
It is my understanding that Amazon has revised its terms of service for its API so as to make it no longer suitable for library use. I think the Koha project should focus its efforts on supporting other sources of third-party content like OpenLibrary.