Bug 5595 - can't search 'searchable' patron attributes
Summary: can't search 'searchable' patron attributes
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) major (vote)
Assignee: Ian Walls
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 6253
  Show dependency treegraph
 
Reported: 2011-01-07 19:58 UTC by Nicole C. Engard
Modified: 2012-10-25 23:04 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
patch (5.54 KB, patch)
2011-03-08 15:09 UTC, Nicole C. Engard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-01-07 19:58:23 UTC
It used to be that if an attribute was marked as 'searchable' you could search by it in the patron search box. I have tried this on 2 systems and someone else has tested on theirs and searchable attribute type values are not actually searchable anymore.
Comment 1 Ian Walls 2011-01-08 23:07:41 UTC
Git Bisect shows the problem is introduced with commit 9d9d933d
Comment 2 Nicole C. Engard 2011-03-01 13:16:25 UTC
I don't know enough to revert a commit or restore this functionality, can someone point me in the right direction or maybe fix this? :)
Comment 3 Nicole C. Engard 2011-03-08 15:09:48 UTC
Created attachment 3267 [details] [review]
patch
Comment 4 Chris Cormack 2011-03-11 23:53:50 UTC
Pushed, please test and mark resolved
Comment 5 Chris Cormack 2011-03-12 00:57:48 UTC
This is causing the test for Members.pm to fail

 perl t/db_dependent/Members.t
ok 1 - use C4::Members;
DBD::mysql::st execute failed: Duplicate entry 'TESTCARD01' for key 'cardnumber' at C4/SQLHelper.pm line 147.
ok 2 - Got member
Use of uninitialized value in pattern match (m//) at C4/SQLHelper.pm line 336.
Use of uninitialized value in pattern match (m//) at C4/SQLHelper.pm line 336.
Use of uninitialized value in pattern match (m//) at C4/SQLHelper.pm line 336.
ok 3 - Member Changed
Use of uninitialized value in pattern match (m//) at C4/SQLHelper.pm line 336.
Use of uninitialized value in pattern match (m//) at C4/SQLHelper.pm line 336.
Use of uninitialized value in pattern match (m//) at C4/SQLHelper.pm line 336.
ok 4 - Member Returned
Use of uninitialized value in pattern match (m//) at C4/SQLHelper.pm line 336.
Use of uninitialized value in pattern match (m//) at C4/SQLHelper.pm line 336.
Use of uninitialized value in pattern match (m//) at C4/SQLHelper.pm line 336.
Not an ARRAY reference at C4/Members/Attributes.pm line 105.
# Looks like you planned 15 tests but ran 4.
# Looks like your test exited with 255 just after 4.

Updating the test needs to be done, and bonus points given for adding a new test to test the functionality this patch adds.
Comment 6 Chris Cormack 2011-03-15 03:24:53 UTC
Follow up patch pushed fixing the test, and a coding style change made