Bug 5615 - ZOOM error 20003 "can't set prefix query" on some authority searches
Summary: ZOOM error 20003 "can't set prefix query" on some authority searches
Status: CLOSED DUPLICATE of bug 4309
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: rel_3_2
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-13 15:13 UTC by Frédérick Capovilla
Modified: 2012-10-26 00:41 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Fixes the search queries of the SearchAuthorities subroutine. (1.32 KB, patch)
2011-01-13 15:13 UTC, Frédérick Capovilla
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Frédérick Capovilla 2011-01-13 15:13:03 UTC
Created attachment 2986 [details] [review]
Fixes the search queries of the SearchAuthorities subroutine.

With some types of authority searches, a ZOOM error is sent : 

Example 1:

In /koha/authorities/authorities-home.pl , If I search for a "Corporate Name" without entering any search term, I get the error :

ZOOM error 20003 "can't set prefix query" (addinfo: "@or @attr 7=1 @attr 1=Heading 0  @and  @attr 1=authtype @attr 5=100 CORPO_NAME") from diag-set 'ZOOM'


Example 2:

When adding or modifying a MARC record, click on the "..." next to the 100$a field to do an authority search.
In the search window, any search with 0 or more than 1 search term returns a ZOOM error :

ZOOM error 20003 "can't set prefix query" (addinfo: "@or @attr 7=1 @attr 1=Heading 0  @and  @attr 1=authtype @attr 5=100 PERSO_NAME @attr 1=Heading  @attr 5=1 @attr 4=6 "test" @attr 1=Heading  @attr 5=1 @attr 4=6 "test"") from diag-set 'ZOOM'


There was a problem in the way the SearchAuthorities subroutine in C4/AuthoritiesMarc.pm created its search queries.

Patch attached to correct the problem.
Comment 1 Frédéric Demians 2011-01-20 09:40:30 UTC
I confirm this bug. I send a patch since I can't sign on the previous one.

http://lists.koha-community.org/pipermail/koha-patches/2011-January/013677.html

Please, Frédérick, test it and put a signed-off on it.
Comment 2 Frédérick Capovilla 2011-01-24 16:31:39 UTC
(In reply to comment #1)
> I confirm this bug. I send a patch since I can't sign on the previous one.
> 
> http://lists.koha-community.org/pipermail/koha-patches/2011-January/013677.html
> 
> Please, Frédérick, test it and put a signed-off on it.

I tested your version of the patch, but there is a small problem with it :
If I do an empty search or a search sorted by "No order", I still get errors.

I think the patch I attached with my bug report fixes the problem better.

Still waiting for somebody to test it and sign off.
Comment 3 Frédéric Demians 2011-01-25 07:24:17 UTC

*** This bug has been marked as a duplicate of bug 4309 ***