Bug 5645 - Z39.50 search from search results not parsing query correctly
Summary: Z39.50 search from search results not parsing query correctly
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Galen Charlton
QA Contact: Marcel de Rooy
URL:
Keywords:
: 7471 10034 (view as bug list)
Depends on: 10742
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-20 19:13 UTC by Ian Walls
Modified: 2014-05-26 21:04 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 5645: improve converting simple search to Z39.50 search (2.40 KB, patch)
2013-09-07 18:51 UTC, Galen Charlton
Details | Diff | Splinter Review
Bug 5645: improve converting simple search to Z39.50 search (2.49 KB, patch)
2013-09-23 12:08 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 5645: improve converting simple search to Z39.50 search (2.51 KB, patch)
2013-10-01 20:58 UTC, sandboxes@biblibre.com
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Walls 2011-01-20 19:13:59 UTC
When searching in only 1 index (kw,wrdl: for example), then clicking the 'Z39.50 Search' button from the search results, the index prefix is not removed from the search term as it's filled into the boxes of the Z39.50 search page.  This is not a problem for two or more separate search fields.
Comment 1 Gaetan Boisson 2012-09-20 14:12:26 UTC
*** Bug 7471 has been marked as a duplicate of this bug. ***
Comment 2 Gaetan Boisson 2012-09-20 14:14:21 UTC
Confirmed, still a bug.

See Liz Rea's screenshot from bug 7471 :

http://screencast.com/t/Zi2saYeF9sz
Comment 3 Owen Leonard 2013-03-26 16:01:18 UTC
(In reply to comment #0)
> This is not a problem for two or more separate search fields.

I still see this bug in master as of 3.12 beta1, and I don't find the above statement to be true.
Comment 4 Galen Charlton 2013-09-07 18:34:06 UTC
*** Bug 10034 has been marked as a duplicate of this bug. ***
Comment 5 Galen Charlton 2013-09-07 18:35:40 UTC
The patch for bug 10742 fixes the case when the main search returns no results.  I will shortly be attaching a patch that fixes this when the main search *does* return results.
Comment 6 Galen Charlton 2013-09-07 18:51:23 UTC Comment hidden (obsolete)
Comment 7 Marcel de Rooy 2013-09-23 12:08:42 UTC Comment hidden (obsolete)
Comment 8 Marcel de Rooy 2013-09-23 12:09:50 UTC
Looks good to me. Works as advertised. No qa complaints.

Passed QA
Comment 9 Katrin Fischer 2013-09-23 16:32:32 UTC
This was missing a sign off when it got QA'd. I am switching back to 'needs signoff' so it gets on the radar of testers. Please switch to 'passed QA' if testing is successful.
Comment 10 sandboxes@biblibre.com 2013-10-01 20:58:12 UTC
Patch tested with a sandbox, by Josef Moravec <josef.moravec@gmail.com>
Comment 11 sandboxes@biblibre.com 2013-10-01 20:58:32 UTC
Created attachment 21705 [details] [review]
Bug 5645: improve converting simple search to Z39.50 search

This patch builds on the patch for bug 10742 by ensuring
that when a search initiated from the staff interface simple
search returns results, if you click on the Z39.50 search
button, the search form is populated with the search string
without "kw,wrdl".

To test:

[1] Perform a search in the staff interface that will return
    results.
[2] Click the Z39.50 search button.
[3] Observe that the search string appears in the title
    field in the Z39.50 search form, but with a prefix of
    "kw,wrdl".
[4] Apply the patch.
[5] Repeat steps 1-2.  This time, the search string appears
    without the index prefix.  This will make the Z39.50 search
    much more likely to work.
[6] Repeat steps 1-2, but with a search that does *not* return
    any hits in the Koha database.

Signed-off-by: Galen Charlton <gmc@esilibrary.com>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 12 Marcel de Rooy 2013-10-02 11:16:13 UTC
Changing status with reference to comment8
Comment 13 Galen Charlton 2013-10-02 14:59:18 UTC
Pushed to master.
Comment 14 Tomás Cohen Arazi 2013-11-13 17:35:53 UTC
This patch has been pushed to 3.12.x, will be in 3.12.7.

Thanks Galen!