Bug 5672 - Add RSS feeds to catalog search history
Summary: Add RSS feeds to catalog search history
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: Viktor Sarge
QA Contact: Bugs List
URL: /cgi-bin/koha/opac-search-history.pl
Whiteboard:
Keywords:
: 11968 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-31 15:17 UTC by Nicole C. Engard
Modified: 2015-12-03 22:11 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
5672 Gives RSS icons to search history (3.55 KB, patch)
2014-06-17 08:40 UTC, Viktor Sarge
Details | Diff | Splinter Review
[SIGNED-OFF] 5672 Gives RSS icons to search history (3.63 KB, patch)
2014-06-17 13:42 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Bug 5672 Gives RSS icons to search history placed to the left of saved searches (4.58 KB, patch)
2014-06-19 09:42 UTC, Viktor Sarge
Details | Diff | Splinter Review
5672 Gives RSS icons to search history (3.66 KB, patch)
2014-06-19 09:49 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 5672 Gives RSS icons to search history placed to the left of saved searches (4.63 KB, patch)
2014-06-19 09:49 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 5672 Gives RSS icons to catalog search history (3.74 KB, patch)
2014-06-19 12:00 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 5672 Gives RSS icons to catalog search history placed to the left of saved searches (4.70 KB, patch)
2014-06-19 12:00 UTC, Jonathan Druart
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 5672 Gives RSS icons to catalog search history placed to the left of saved searches (4.76 KB, patch)
2014-06-19 13:21 UTC, Nicole C. Engard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-01-31 15:17:41 UTC
It would be great to add a column to the search history tab in the OPAC with an RSS feed next to each search to allow patrons to easily subscribe to each of their saved searches (since each one has an RSS feed already it should be easy to add).
Comment 1 Nicole C. Engard 2013-01-23 12:53:14 UTC
This would still be a cool feature and probably not that hard to implement since the searches all have RSS feeds already.
Comment 2 Viktor Sarge 2014-06-17 08:33:44 UTC
*** Bug 11968 has been marked as a duplicate of this bug. ***
Comment 3 Viktor Sarge 2014-06-17 08:40:27 UTC Comment hidden (obsolete)
Comment 4 Nicole C. Engard 2014-06-17 13:42:32 UTC Comment hidden (obsolete)
Comment 5 Jonathan Druart 2014-06-18 15:13:42 UTC
All looks good. But one icon in a cell does not seem very elegant.

Maybe Owen has a brainwave?
Comment 6 Nicole C. Engard 2014-06-18 18:21:28 UTC
I'd say just have the RSS icon to the left of the search terms without a header row. The icon is pretty clear on it's own.  But I signed off cause it got the functionality in there and figured a follow up could make it pretty.
Comment 7 Viktor Sarge 2014-06-19 08:49:15 UTC
(In reply to Nicole C. Engard from comment #6)
> I'd say just have the RSS icon to the left of the search terms without a
> header row. The icon is pretty clear on it's own.  But I signed off cause it
> got the functionality in there and figured a follow up could make it pretty.

To the left of the search sounds good. It's an easy fix but what's the workflow for fixing that? Should I submit a new patch to this thread even though it's signed off? Or do I have to wait until the patch is pushed to master until I can pick it up and change it?
Comment 8 Jonathan Druart 2014-06-19 09:01:34 UTC
(In reply to Viktor Sarge from comment #7)
> To the left of the search sounds good. It's an easy fix but what's the
> workflow for fixing that? Should I submit a new patch to this thread even
> though it's signed off? Or do I have to wait until the patch is pushed to
> master until I can pick it up and change it?

You can submit a follow-up on this bug report and switch the status back to "Needs Signoff".
Comment 9 Viktor Sarge 2014-06-19 09:26:55 UTC
> You can submit a follow-up on this bug report and switch the status back to
> "Needs Signoff".

Seems I have messed something up with my git. It won't add the file again since it thinks nothing is changed. Working on it since it RSS icons to the left of the search instead looks quite a bit better.
Comment 10 Viktor Sarge 2014-06-19 09:42:27 UTC Comment hidden (obsolete)
Comment 11 Chris Cormack 2014-06-19 09:49:17 UTC Comment hidden (obsolete)
Comment 12 Chris Cormack 2014-06-19 09:49:35 UTC Comment hidden (obsolete)
Comment 13 Jonathan Druart 2014-06-19 12:00:27 UTC
Created attachment 29010 [details] [review]
Bug 5672 Gives RSS icons to catalog search history

This patch adds an extra column to the table for the search history (this session and previous searches) with RSS icons for each search.

Test plan:
* Verify that there is no RSS icons for saved searches in opac
* Install the patch
* Verify that there is no RSS icons for saved searches and searches for the current session in Opac.
* Test that the RSS links produce the expected result.

Note: I left out authority searches since I have very little experience with authority searches and didn't feel I could test it properly.
Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>
Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Comment 14 Jonathan Druart 2014-06-19 12:00:33 UTC Comment hidden (obsolete)
Comment 15 Jonathan Druart 2014-06-19 12:01:25 UTC
I updated bug report summary and commit message to highlight that the patches only affect catalog search history (not authority).
Comment 16 Nicole C. Engard 2014-06-19 13:21:58 UTC
Created attachment 29018 [details] [review]
[SIGNED-OFF] Bug 5672 Gives RSS icons to catalog search history placed to the left of saved searches

Test plan:
* Verify that there is no RSS icons for saved searches in opac
* Install the patch
* Verify that there is no RSS icons for saved searches and searches for the current session in Opac.
* Test that the RSS links produce the expected result.

Note: I left out authority searches since I have very little experience with authority searches and didn't feel I could test it properly.
Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>

Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>
Comment 17 Nicole C. Engard 2014-06-19 13:23:12 UTC
Sorry, I missed an update in my email and didn't check here - so I signed off after QA again :)
Comment 18 Tomás Cohen Arazi 2014-08-10 13:23:45 UTC
Patches pushed to master.

Thanks Viktor!