Bug 5696 - Hold deletion should use reservenumber
Summary: Hold deletion should use reservenumber
Status: RESOLVED DUPLICATE of bug 9394
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Kyle M Hall
QA Contact: Bugs List
URL:
Keywords:
Depends on: 7065 9394
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-04 14:31 UTC by Owen Leonard
Modified: 2013-05-29 13:06 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2011-02-04 14:31:08 UTC
Now that we have a reservenumber column in the reserves table (Bug 4806), the holds deletion process (Reserves::ModReserve) should use reservenumber instead of borrowernumber + biblionumber. Making this change would allow the deletion of one duplicate hold without deleting all duplicate copies of the hold at once.
Comment 1 Paul Poulain 2011-09-28 14:12:40 UTC
I've suggested to revert 4806, as the main bug for reservenumber has never been applied. If bug 4608 is reverted, then owen comment become irrelevant, even if it's still a good idea to have reservenumber in the reserve/old_reserve table
Comment 2 Katrin Fischer 2013-04-13 22:39:32 UTC
We now have a unique key for reserves and old_reserves and also a patch to make all subs use that number (see bug 7065 and bug 9394).
Comment 3 Jonathan Druart 2013-05-29 13:06:09 UTC

*** This bug has been marked as a duplicate of bug 9394 ***