Bug 5713 - Intranet - Circulation - Fines : debug calculation when fines are reversed then re-payed
Summary: Intranet - Circulation - Fines : debug calculation when fines are reversed th...
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: 3.4
Hardware: All All
: PATCH-Sent (DO NOT USE) major (vote)
Assignee: Brice Sanchez
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-08 15:03 UTC by Brice Sanchez
Modified: 2012-10-25 23:10 UTC (History)
6 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
patch for this bug (2.43 KB, patch)
2011-02-08 15:09 UTC, Brice Sanchez
Details | Diff | Splinter Review
patch for this bug (2.43 KB, patch)
2011-02-08 18:05 UTC, Brice Sanchez
Details | Diff | Splinter Review
Signed off patch (2.73 KB, patch)
2011-05-21 19:29 UTC, Katrin Fischer
Details | Diff | Splinter Review
proposed patch (passed QA) (2.97 KB, patch)
2011-08-04 13:08 UTC, Paul Poulain
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Brice Sanchez 2011-02-08 15:03:51 UTC
When a user has fines and we pay them and then we click to reverse them and after the pay them again, the calculation isn't done properly.

Adrien Russo (SYS-TECH) provides you a patch to fix this problem: we do not create more new line after paying a fine, we edit it.
Comment 1 Brice Sanchez 2011-02-08 15:09:43 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2011-02-08 17:14:32 UTC
I tried to apply this patch using git am and got this message:

Applying: debug calculation when fines are reversed then re-payed
fatal: corrupt patch at line 77
Repository lacks necessary blobs to fall back on 3-way merge.
Cannot fall back to three-way merge.
Patch failed at 0001 debug calculation when fines are reversed then re-payed
Comment 3 Brice Sanchez 2011-02-08 18:05:25 UTC Comment hidden (obsolete)
Comment 4 Brice Sanchez 2011-02-08 18:07:11 UTC
try this patch, it should be good.
Comment 5 Katrin Fischer 2011-05-21 19:29:12 UTC Comment hidden (obsolete)
Comment 6 Paul Poulain 2011-08-04 13:08:24 UTC
Created attachment 4841 [details] [review]
proposed patch (passed QA)

QA comment

* the indentation was made with <TAB> => brice = please use 4 spaces, this is the common rule for Koha. I've fixed the problem, but next time, i'll mark "failed QA"

* The patch was conflicting with 6305 (removal of 3 my $sth). Solving the conflict was easy, so I made it too

* Same comment as Katrin: could not reproduce the calculation error, but confirm accountlines table is not filled and filled and filled by payements/revers/payement

=> marking passed QA
Comment 7 Chris Cormack 2011-08-16 22:27:30 UTC
Pushed please test
Comment 8 Liz Rea 2011-08-22 16:35:36 UTC
Tested, works great thanks!