Bug 5781 - Cannot delete order if attached biblio does no longer exist
Summary: Cannot delete order if attached biblio does no longer exist
Status: RESOLVED DUPLICATE of bug 10869
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Henri-Damien LAURENT
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 8149
  Show dependency treegraph
 
Reported: 2011-02-21 08:09 UTC by Marcel de Rooy
Modified: 2013-09-17 19:00 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel de Rooy 2011-02-21 08:09:36 UTC
Add an order
Delete the attached biblio
Go back to basket
Try to delete order: not possible!

Bug in current master, commita0367aa973ad61eda090d743cccd9cf387dfcc09 (Fix for Bug 5776 - menu on funds wraps when only 1 fund)
Comment 1 Gaetan Boisson 2012-09-13 16:09:16 UTC
This bug is still current in master.
Comment 2 Gaetan Boisson 2012-09-13 16:16:12 UTC
Ideally i think the order should be deleted as well when deleting the biblio, with a specific warning about the user is about to do, and a permission check : the user should not be allowed to delete the biblio if he has no permissions on acquisitions.

Alternatively, the alert could just say "there is an order on this biblio and it cannot be deleted" and link directly to the order. From there the user could delete both order and biblio.

There is no screen to manage just a biblio though, so the user should be redirected on the basket page as long as the basket wasn't closed and on the reception page if the basket was closed.

Biblios in basket that have been closed but in a basket group that is still open, or in no basket group, drift in limbo somewhere in between.
Comment 3 mathieu saby 2013-03-18 15:32:06 UTC
Bug still in master
M. Saby
Comment 4 mathieu saby 2013-03-18 15:43:53 UTC
It will probably be fixed more or less by bug 9780 that will prevent a librarian to suppress a record if used in an order.

M. Saby
Comment 5 mathieu saby 2013-09-17 18:59:41 UTC
I made a patch for that : bug 10869
You can test it and sign off.

M. Saby
Comment 6 mathieu saby 2013-09-17 19:00:07 UTC

*** This bug has been marked as a duplicate of bug 10869 ***