Bug 5795 - Missing ReservesControlBranch system pref in database installer
Summary: Missing ReservesControlBranch system pref in database installer
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (web-based installer) (show other bugs)
Version: 3.6
Hardware: All All
: P3 normal (vote)
Assignee: Katrin Fischer
QA Contact: Jonathan Druart
URL:
Keywords:
: 7970 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-22 16:41 UTC by Fridolin SOMERS
Modified: 2013-12-05 19:59 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 5795 - Missing ReservesControlBranch system pref in database installer (1.67 KB, patch)
2012-04-14 11:15 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 5795 [SIGNED-OFF] - Missing ReservesControlBranch system pref in database installer (2.00 KB, patch)
2012-04-27 19:10 UTC, Marc Véron
Details | Diff | Splinter Review
Update the database as follow-up to Bug 5795 (2.36 KB, patch)
2012-05-03 12:23 UTC, Amit Gupta
Details | Diff | Splinter Review
Update the database as follow-up to Bug 5795 (2.18 KB, patch)
2012-05-08 11:27 UTC, Amit Gupta
Details | Diff | Splinter Review
Bug 5795 [SIGNED-OFF] - Missing ReservesControlBranch system pref in database installer (1.97 KB, patch)
2012-05-14 00:11 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 5795 Update the database as follow-up If sys pref ReservesControlBranch has null then update the table to insert a ItemHomeLibrary as value (2.22 KB, patch)
2012-05-14 00:13 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 5795 Update the database as follow-up If sys pref ReservesControlBranch has null then update the table to insert a PatronLibrary as value (2.17 KB, patch)
2012-05-22 10:33 UTC, Amit Gupta
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Fridolin SOMERS 2011-02-22 16:41:13 UTC
Hie,

"ReservesControlBranch" system preference is present in interface and udpatedatabase.pl but not in SQL installation scripts "sysprefs.sql".

It's quite buggy in a fresh installation.

Regards,
Comment 1 Katrin Fischer 2012-04-14 11:10:19 UTC
This bug is still valid for current master.
Comment 2 Katrin Fischer 2012-04-14 11:15:57 UTC Comment hidden (obsolete)
Comment 3 Marc Véron 2012-04-27 19:10:55 UTC Comment hidden (obsolete)
Comment 4 Amit Gupta 2012-05-03 12:23:09 UTC Comment hidden (obsolete)
Comment 5 Amit Gupta 2012-05-08 11:27:35 UTC Comment hidden (obsolete)
Comment 6 Fridolin SOMERS 2012-05-09 14:31:38 UTC
Can we define Bug 7970 has duplicate of this one ?
No need to have the same patche in two bugs.
Comment 7 Amit Gupta 2012-05-10 03:24:10 UTC
Fridolyn SOMERS

You can mark  bug 7970 as a duplicate.
Comment 8 Amit Gupta 2012-05-10 03:25:14 UTC
*** Bug 7970 has been marked as a duplicate of this bug. ***
Comment 9 Chris Cormack 2012-05-14 00:11:35 UTC
Created attachment 9541 [details] [review]
Bug 5795 [SIGNED-OFF] - Missing ReservesControlBranch system pref in database installer

sysprefs.sql file was missing ReservesControlBranch.

To test:
1) Create a new installation and check sysprefs.sql loads correctly.
2) Check ReservesControlBranch shows up correctly in the sys pref editor.
3) Check sys pref can be edited and new value saves correctly.

Signed-off-by: Marc Veron <veron@veron.ch>

- Line is added at the end of installer/data/mysql/sysprefs.sql
- Tested Line diretly in MySQL with a systempreferences table where variable 'ReservesControlBranch' was missing. Data inserted correctly.
- Syspref shows up in Staff client

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>

- Fixed merge conflict
Comment 10 Chris Cormack 2012-05-14 00:13:01 UTC Comment hidden (obsolete)
Comment 11 Jonathan Druart 2012-05-22 10:23:40 UTC
QA Comments,
A little comment: First patch (syspref.sql) insert the syspref with the "PatronLibrary" default value whereas updatedatabase insert with "ItemHomeLibrary".

Marking as Failed QA.
Comment 12 Amit Gupta 2012-05-22 10:31:04 UTC
PatronLibrary as default value.
Comment 13 Amit Gupta 2012-05-22 10:33:00 UTC
Created attachment 9695 [details] [review]
Bug 5795 Update the database as follow-up If sys pref  ReservesControlBranch has null then update the table to insert a PatronLibrary as value

Bug 5795 Update the database as follow-up If sys pref

ReservesControlBranch has null then update the table to
insert a PatronLibrary as value

To Test:
1) Go to mysql use koha database
2) select * from systempreferences where variable = 'ReservesControlBranch'; Check if value set to ItemHomeLibrary.
+-----------------------+-----------------+-------------------------------+-------------------------------------------------+--------+
| variable              | value           | options                       | explanation                                     | type   |
+-----------------------+-----------------+-------------------------------+-------------------------------------------------+--------+
| ReservesControlBranch | PatronLibrary   | ItemHomeLibrary|PatronLibrary | Branch checked for members reservations rights. | Choice |
+-----------------------+-----------------+-------------------------------+-------------------------------------------------+--------+


PatronLibrary as default value.
Comment 14 Jonathan Druart 2012-05-22 12:05:28 UTC
Previous patch is already signed off by Chris
Comment 15 Jonathan Druart 2012-05-22 12:05:40 UTC
QA comment:

Last patch modify the default value for the syspref.

Marking as Passed QA
Comment 16 Chris Cormack 2012-05-28 09:47:34 UTC
Pushed to 3.8.x, will be in 3.8.2