Bug 5847 - Manage Staged MARC Records stuck at 0% if isbn matching rule selected.
Summary: Manage Staged MARC Records stuck at 0% if isbn matching rule selected.
Status: CLOSED WORKSFORME
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Bibliographic record staging/import (show other bugs)
Version: master
Hardware: All All
: P1 - high critical (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-10 04:45 UTC by Koustubha Kale
Modified: 2019-06-27 09:24 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
screen shot showing rules selected during import (160.30 KB, image/png)
2011-03-10 04:47 UTC, Koustubha Kale
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Koustubha Kale 2011-03-10 04:45:19 UTC
If we try to use ISBN match rule while importing a staged batch, the Manage Staged MARC Records gets stuck at 0%. I can see a www-data owned background job running but the browser is stuck at 0% and no entries in the db. Tried leaving it overnight with no progress. Tried with firefox and chrome.  

Same MARC file is imported fine without using the ISBN match rule. The same marc records file imports fine with bulkmarcimport.pl utility even with the -isbn option. Sadly the bulkmarcimport.pl lacks the option to still add items even while ignoring a biblio if a isbn match is found.

See attached screenshot for rules used during this import.
Comment 1 Koustubha Kale 2011-03-10 04:47:27 UTC
Created attachment 3277 [details]
screen shot showing rules selected during import

screen shot showing rules selected during import

BTW I am using 3.03.00.019 with perl 5.10.1 on ubuntu 10.10
Comment 2 Nicole C. Engard 2011-06-02 16:55:23 UTC
Any clues on this one?
Comment 3 delaye 2012-03-15 13:39:46 UTC
I confirm I also had this problem with a base in UNIMARC and a rule on a $ 010
blocking does not always happen with the first notice, blocking may reach 10% or 80% of the file. 
file attached : file iso unimarc for test
Comment 4 Owen Leonard 2014-07-10 17:27:19 UTC
Unless we can get new data on how to reproduce this problem I think we can consider this to be working. We use an ISBN matching rule for importing records on a regular basis without problems.