Bug 5870 - Enhancements to suggestions management
Summary: Enhancements to suggestions management
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: 3.4
Hardware: All All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Assignee: Paul Poulain
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 5580
  Show dependency treegraph
 
Reported: 2011-03-15 23:52 UTC by Chris Cormack
Modified: 2012-10-25 23:03 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed Patch (10.66 KB, patch)
2011-03-15 23:56 UTC, Chris Cormack
Details | Diff | Splinter Review
Followup patch (1.76 KB, patch)
2011-03-28 01:34 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2011-03-15 23:52:44 UTC

    
Comment 1 Chris Cormack 2011-03-15 23:54:36 UTC
* changing suggestedy management
* adding a new status field & filter
Comment 2 Chris Cormack 2011-03-15 23:56:22 UTC
Created attachment 3308 [details] [review]
Proposed Patch
Comment 3 Owen Leonard 2011-03-16 14:13:28 UTC
I'm getting a JS error on suggestion.pl:

document.getElementById("quantity") is null
/intranet-tmpl/prog/en/js/acq.js
Line 686

Perhaps because I have no suggestions?
Comment 4 Nicole C. Engard 2011-03-16 16:26:03 UTC
Apply? [y]es/[n]o/[e]dit/[v]iew patch/[a]ccept all y
Applying: Bug 5870 : suggestion management enhancements
fatal: corrupt patch at line 138
Repository lacks necessary blobs to fall back on 3-way merge.
Cannot fall back to three-way merge.
Patch failed at 0001 Bug 5870 : suggestion management enhancements
When you have resolved this problem run "git am --resolved".
If you would prefer to skip this patch, instead run "git am --skip".
To restore the original branch and stop patching run "git am --abort".
nengard@debian:~/kohaclone$
Comment 5 Owen Leonard 2011-03-16 16:31:56 UTC
It applied fine for me.
Comment 6 Nicole C. Engard 2011-03-16 17:11:52 UTC
Did you pull from master this morning before applying? Not sure why it's not applying on mine - guess we need someone else to test.

Nicole
Comment 7 Julian Maurice 2011-03-24 09:09:34 UTC
It applies fine for me too and it works well.
Signed off.
Comment 8 Chris Cormack 2011-03-27 07:56:36 UTC
Julian, did you test the error Owen was getting. Id like this error investigated before I push it to master
Comment 9 Chris Cormack 2011-03-28 01:32:18 UTC
Attaching a follow up patch, 

* followup debug suggestion management : "accepted by" was not correctly displayed on suggestion's edit page

* suggestion's status, document's type and "accepted by" was not correctly displayed on suggestion's edit page
Comment 10 Chris Cormack 2011-03-28 01:34:24 UTC
Created attachment 3450 [details] [review]
Followup patch
Comment 11 Julian Maurice 2011-03-28 07:21:11 UTC
(In reply to comment #8)
> Julian, did you test the error Owen was getting. Id like this error
> investigated before I push it to master

I didn't manage to reproduce the bug, even with no suggestions. So I can't tell you more about this.
Comment 12 Chris Cormack 2011-04-02 06:44:12 UTC
Pushed, please test
Comment 13 MJ Ray (software.coop) 2011-04-06 13:52:36 UTC
This bug is mentioned in:
Bug 5870 : suggestion management enhancements http://lists.koha-community.org/pipermail/koha-patches/2011-March/014063.html
Bug 5870 : suggestion	management enhancements http://lists.koha-community.org/pipermail/koha-patches/2011-March/014213.html
Bug 5870 : Follow up clean up patch http://lists.koha-community.org/pipermail/koha-patches/2011-March/014247.html