Bug 5897 - Hide name of reviewer / comment writer in OPAC
Summary: Hide name of reviewer / comment writer in OPAC
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-18 21:53 UTC by Katrin Fischer
Modified: 2013-12-05 20:04 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Patch adding new syspref ShowReviewer (16.75 KB, patch)
2011-03-27 13:29 UTC, Katrin Fischer
Details | Diff | Splinter Review
Follow-up fix for recent comments page (3.92 KB, patch)
2011-04-19 18:58 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2011-03-18 21:53:55 UTC
It should be possible to hide/not show the name of the patron who wrote a comment in the OPAC. (privacy)
Comment 1 Katrin Fischer 2011-03-27 13:29:04 UTC
Created attachment 3441 [details] [review]
Patch adding new syspref ShowReviewer

This patch adds a new syspref ShowReviewer.

If ON (default) the reviewer/author of an OPAC comment will show.
If OFF the reviewer's name will be hidden.
Comment 2 Nicole C. Engard 2011-03-28 12:02:28 UTC
Apply? [y]es/[n]o/[e]dit/[v]iew patch/[a]ccept all y
Applying: Bug 5897: Add new syspref ShowReviewer
Using index info to reconstruct a base tree...
Falling back to patching base and 3-way merge...
Auto-merging installer/data/mysql/de-DE/mandatory/sysprefs.sql
Auto-merging installer/data/mysql/en/mandatory/sysprefs.sql
Auto-merging installer/data/mysql/fr-FR/1-Obligatoire/unimarc_standard_systemprefs.sql
Auto-merging installer/data/mysql/it-IT/necessari/sysprefs.sql
Auto-merging installer/data/mysql/pl-PL/mandatory/sysprefs.sql
Auto-merging installer/data/mysql/ru-RU/mandatory/system_preferences_full_optimal_for_install_only.sql
Auto-merging installer/data/mysql/uk-UA/mandatory/system_preferences_full_optimal_for_install_only.sql
Auto-merging installer/data/mysql/updatedatabase.pl
Auto-merging kohaversion.pl
CONFLICT (content): Merge conflict in kohaversion.pl
Failed to merge in the changes.
Patch failed at 0001 Bug 5897: Add new syspref ShowReviewer
When you have resolved this problem run "git am --resolved".
If you would prefer to skip this patch, instead run "git am --skip".
To restore the original branch and stop patching run "git am --abort".
nengard@debian:~/kohaclone$
Comment 3 Nicole C. Engard 2011-03-28 12:13:25 UTC
Signed off after editing kohaversion  (where the conflict was)
Comment 4 Chris Cormack 2011-04-01 07:26:38 UTC
Pushed, please test
Comment 5 Nicole C. Engard 2011-04-01 17:12:35 UTC
Should I submit this as another enhancement? I'd like to see this preference expanded to also let people choose to show just the first name or just the username in addition to the full name or nothing at all.  Other than that request it works.
Comment 6 MJ Ray (software.coop) 2011-04-10 11:25:08 UTC
This bug is mentioned in:
Bug 5897: Add new syspref ShowReviewer http://lists.koha-community.org/pipermail/koha-patches/2011-March/014269.html
Bug 5897: Add new syspref ShowReviewer http://lists.koha-community.org/pipermail/koha-patches/2011-March/014238.html
Comment 7 Owen Leonard 2011-04-19 18:41:33 UTC
opac-showreviews.tt needs this change as well.
Comment 8 Owen Leonard 2011-04-19 18:58:06 UTC
Created attachment 3951 [details] [review]
Follow-up fix for recent comments page
Comment 9 Nicole C. Engard 2011-04-20 00:45:43 UTC
Owen, I tested the follow up patch but no matter what i change 'showreviewer' to the name still shows.  I am not logged in to the opac when this is happening and it's FF4 and Chrome that I have tested.
Comment 10 Nicole C. Engard 2011-04-20 00:47:56 UTC
Okay this is what I get for working too late ... I created a branch for the patch, but didn't apply the patch :) testing again.
Comment 11 Chris Cormack 2011-04-20 04:19:59 UTC
Pushed, please test
Comment 12 Katrin Fischer 2011-12-13 15:13:07 UTC
*** Bug 5503 has been marked as a duplicate of this bug. ***
Comment 13 Jared Camins-Esakov 2012-12-31 00:13:37 UTC
There have been no further reports of problems so I am marking this bug resolved.