Bug 5957 - COiNS in the OPAC search results should be optional
Summary: COiNS in the OPAC search results should be optional
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: 3.4
Hardware: All All
: PATCH-Sent (DO NOT USE) minor (vote)
Assignee: Ian Walls
QA Contact: Bugs List
URL:
Keywords:
: 6060 (view as bug list)
Depends on:
Blocks: 5729
  Show dependency treegraph
 
Reported: 2011-03-26 00:54 UTC by Ian Walls
Modified: 2012-10-25 23:09 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (27.96 KB, patch)
2011-03-31 22:58 UTC, Chris Cormack
Details | Diff | Splinter Review
Follow-up patch (973 bytes, patch)
2011-04-05 12:24 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
1st signed off (2.44 KB, patch)
2011-04-05 15:50 UTC, claire.hernandez@biblibre.com
Details | Diff | Splinter Review
2nd patch signed off (1011 bytes, patch)
2011-04-05 15:50 UTC, claire.hernandez@biblibre.com
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Walls 2011-03-26 00:54:09 UTC
The use of COins / OpenURL / Z3988 in the OPAC search results should be optional, as adds a great deal of processing time per record returned, slowing search.  

This feature should be disabled by default, so libraries who know they want to use it (and accept the costs) can opt-in
Comment 1 Chris Cormack 2011-03-31 22:58:41 UTC
Created attachment 3598 [details] [review]
Proposed patch
Comment 2 Chris Cormack 2011-03-31 23:08:46 UTC
Pushed please test
Comment 3 Jared Camins-Esakov 2011-04-05 12:24:07 UTC
Created attachment 3678 [details] [review]
Follow-up patch

Follow-up patch changing an incorrect assignment operator to a comparison operator.
Comment 4 Magnus Enger 2011-04-05 12:52:26 UTC
*** Bug 6060 has been marked as a duplicate of this bug. ***
Comment 5 claire.hernandez@biblibre.com 2011-04-05 15:50:06 UTC
Created attachment 3709 [details] [review]
1st signed off
Comment 6 claire.hernandez@biblibre.com 2011-04-05 15:50:32 UTC
Created attachment 3710 [details] [review]
2nd patch signed off
Comment 7 claire.hernandez@biblibre.com 2011-04-05 15:51:36 UTC
This very little patch make sense for me, didn't do some functionnal test (only a return line and an "eq")
Comment 8 Chris Cormack 2011-04-07 04:09:22 UTC
Follow up patch pushed