Bug 5976 - The search button is duplicated on advanced search
Summary: The search button is duplicated on advanced search
Status: CLOSED WONTFIX
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: 3.4
Hardware: All All
: PATCH-Sent (DO NOT USE) minor (vote)
Assignee: Paul Poulain
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 5584
  Show dependency treegraph
 
Reported: 2011-03-28 20:13 UTC by Chris Cormack
Modified: 2012-10-26 00:41 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed Patch (1.37 KB, patch)
2011-03-28 20:24 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2011-03-28 20:13:20 UTC

    
Comment 1 Chris Cormack 2011-03-28 20:24:49 UTC
Created attachment 3477 [details] [review]
Proposed Patch
Comment 2 Nicole C. Engard 2011-03-28 20:24:58 UTC
Not sure what this means, but there are multiple search buttons on the advanced
search page on purpose - it was an added feature a few releases ago to make it
easier if people just want to use one part of the advanced search and not
scroll all the way down.
Comment 3 Nicole C. Engard 2011-03-28 20:25:58 UTC
On reading the patch I see that it is removing the feature - I don't think this patch should be signed off on - but if it's a problem for some libraries it needs a preference to control.
Comment 4 Owen Leonard 2011-03-28 20:29:01 UTC
The duplicate button is a feature, not a bug. If libraries need to be able to hide it I suggest we make sure the markup allows it to be hidden with CSS.
Comment 5 Jane Wagner 2011-03-29 12:08:31 UTC
Yes, I added the extra search button at the top in Bug 3663 at the request of several of my sites.  If there are a lot of item types in the system, a user might have to scroll down a long ways to find the original search button, and we got a lot of complaints about it.  I would hope that this feature stays.
Comment 6 Paul Poulain 2011-04-04 15:47:53 UTC
i'm strongly against a syspref. But i'm OK for a css property. And I agree we can discard this patch.
The problem is that library X want "white" and library Y want "black". Plus library Z prefers green... Sometimes, we must say "hey, it's OpenSource, but we should concentrate on important things..."