Bug 5989 - Funds filter does not remember library choice
Summary: Funds filter does not remember library choice
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL:
Keywords:
: 7200 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-29 16:08 UTC by Owen Leonard
Modified: 2012-10-25 23:10 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed fix (1.13 KB, patch)
2011-03-29 16:10 UTC, Owen Leonard
Details | Diff | Splinter Review
patch signed-off (1.16 KB, patch)
2011-04-04 10:26 UTC, Paul Poulain
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2011-03-29 16:08:17 UTC
If you filter your funds list by library the filter menu doesn't remember the choice you made by preselecting your branch. This is because the script makes itself forget the parameter before it can be used:


74 my $budget_hash               = $input->Vars;
...
79 delete $$budget_hash{$_} foreach grep {/filter|^op$|show/} keys %$budget_hash;
80 my $filter_budgetbranch       = $input->param('filter_budgetbranch');
Comment 1 Owen Leonard 2011-03-29 16:10:55 UTC Comment hidden (obsolete)
Comment 2 Paul Poulain 2011-04-04 10:26:26 UTC
Created attachment 3612 [details] [review]
patch signed-off
Comment 3 Chris Cormack 2011-04-04 10:54:44 UTC
Pushed please test
Comment 4 Srdjan Jankovic 2011-11-09 05:26:47 UTC
*** Bug 7200 has been marked as a duplicate of this bug. ***